Unable To Attach Subscription

Latest response

Hello,
I'm unable to attach my current "Red Hat Developer Subscription for Individuals" subscription to my VM. In the GUI, I can clearly see my subscription, but when I run "subscription-manager list --available" I get the following output "No available subscription pools to list". In the GUI, if I actually click on the Subscription Name I get 404 page.

I've tried numerous troubleshooting steps, but I'm still unable to attach my subscription. I even tried the following:
sudo subscription-manager remove --all
sudo subscription-manager unregister
sudo subscription-manager clean
sudo subscription-manager register
sudo subscription-manager refresh
sudo subscription-manager attach --auto

Has anybody been able to resolve this issue? I read one post where a user said they just waited a few days and they were finally able to attach their subscription.

Thanks !

Responses

Hi Xavier,

Open https://access.redhat.com/management/subscriptions/product/RH00798/subscriptions, then click on the subscription
number. If there is no Pool ID listed, you have to contact the Red Hat Customer Service team and ask them to add a Pool ID. :)

Regards,
Christian

Hey Christian,

Will try the above. Thanks !

You're welcome, Xavier ! I wish you good luck. :)

Regards,
Christian

Reached out to customer service, and they informed me that there was a temporary issue with system registration. It is resolved now, and I'm able to attach my subscription.

Great Xavier ! Glad to see that the problem has been resolved for you. :)

Regards,
Christian