ansible cannot be installed

Latest response

Hi,

I've tied version to 8.4 and now ansible cannot be installed:

dnf install ansible

Updating Subscription Management repositories.
Last metadata expiration check: 5:57:18 ago on Wed 08 Jun 2022 01:15:11 AM CEST.
Error:
Problem: conflicting requests
- nothing provides (ansible-core >= 2.12.2 with ansible-core < 2.13) needed by ansible-5.4.0-2.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Any idea how to fix this?

TIA
Roland

Responses

Hi Roland,

The ansible package has been deprecated ... You will have to install the ansible-core package. :)

https://access.redhat.com/downloads/content/ansible-core/2.12.2-3.1.el8/x86_64/fd431d51/package

sudo dnf install ansible-core

Regards,
Christian

Hi Christian,

Thanks for your quick reply.

Is there a new repository needed?

dnf install ansible-core
Updating Subscription Management repositories.
Last metadata expiration check: 3:33:57 ago on Wed 08 Jun 2022 08:05:49 AM CEST.
No match for argument: ansible-core
Error: Unable to find a match: ansible-core
dnf repolist
Updating Subscription Management repositories.
repo id                                                                            repo name
epel                                                                               Extra Packages for Enterprise Linux 8 - x86_64
epel-modular                                                                       Extra Packages for Enterprise Linux Modular 8 - x86_64
rhel-8-for-x86_64-appstream-rpms                                                   Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)
rhel-8-for-x86_64-baseos-rpms                                                      Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)

Regards,
Roland

Hi Roland,

No additional repo needed, ansible-core is available from the rhel-8-for-x86_64-appstream-rpms repository.
Not sure if it's available in the 8.4 repository though, you may want to unlock the locked version temporarily. :)

Regards,
Christian

Hi Roland,

FYI : Here you can see that ansible-core is available from the RHEL 8.6 repositories ... :)

sudo dnf list ansible-core
Available Packages
ansible-core.x86_64        2.12.2-3.1.el8        rhel-8-for-x86_64-appstream-rpms

Regards,
Christian

Hi,

Unfortunately, we have to stay with 8.4 (due to legal topics).

Regards,
Roland

Hi Roland,

A little hint/tip ... You can download the rpm package (see the link in my first response), and install it manually. :)

Regards,
Christian

Hi Roland,

You still have the option to install the "old" ansible version 2.9 ... :)
It is available from the ansible-2.9-for-rhel-8-x86_64-rpms repo.
Well, this version won't get updates - but it can be a compromise.

sudo subscription-manager repos --enable ansible-2.9-for-rhel-8-x86_64-rpms

sudo dnf upgrade

sudo dnf install ansible

Regards,
Christian

Hi Roland,

I have checked something ... I see you have the EPEL repository enabled, which offers Ansible as well.
Temporarily disable EPEL and perform one of the options I've provided in my two comment before. :)

Regards,
Christian

Hello, we use both EPEL and ansible-2-for-rhel-8-x86_64-rpms in our RHEL 8.4 environment and therefore experience the ansible-5.4.0-2.el8.noarch blocker as well. I understand that we have to use the "old" ansible verison for now (in fact we even prefer this currently), but having to disable the EPEL repo temporarily is an inconvenient workaround which is no option for us. Is there any deeper reason why the ansible-5.4.0-2.el8.noarch package is not called ansible-collections or similar? this would solve the blocker automatically. Would be great if you could help. kind regards, Marcel