Installing/Using RHEVM as evaluation

Latest response

Hi.

I'm trying to install and use rhev-rhevm. I have successfully installed rhev. However, I have problem when downloading rhevm by yum. I tried to locate Red Hat Enterprise Virtualization Manager, JBoss Application Platform, RHEL Server Supplementary in Alter Channel Subscription but only the Supplementary was there. Could anyone please tell me what I have to do to download and install rhevm?

I really appreciate your help.

Responses

once you have your RHEV Manager system registered to RHN, you should run

[root@rhevm] # rhn-channel --available-channels > ~/rhn-channel_available-channels

you need to make sure you have:

rhel-x86_64-server-6-rhevm-3.1  
jbappplatform-6-x86_64-server-6-rpm  
rhel-x86_64-server-supplementary-6

[root@rhevm] # egrep -i 'rhevm|jbapp|suppl' /tmp/rhn-channel—available-channels
 

-- In my case, I would run:

[root@rhevm] # rhn-channel -v -u RHNuser -a -c rhel-x86_64-server-optional-6 -a -c rhel-x86_64-server-supplementary-6 -a -c jbappplatform-6-x86_64-server-6-rpm -a -c rhel-x86_64-server-6-rhevm-3.1

You may have access to rhevm-3.2 - so, you would need to add that instead.  I can't recall, but I believe if you have demo access, you may have access to beta channels?
 

i'm sorry, when i run rhn-channel --available-channels > ~/rhn-channel_available-channels, there was only rhel-x86_64-server-supplementary-6, rhevm and jbappplatform were not found

here is my available channels:

http://img259.imageshack.us/img259/7199/86i.png

Hi Tri,

Could you please follow the below Red Hat Knowledge base to add the required channels for rhevm 3.1

https://access.redhat.com/site/solutions/303323

With trial subscription also you should be able to add these channels and you can install the rhevm 3.1. It would be better you remove the system from the satellite and re-add again and then subscribe to the channels as mentioned in the above Knowledge base.

 

BR,

Uday

Thanks for your suggestion. I did as below:

_ Deleted my system in Classic Subscription Management and registered again with rhn_register

_ Tried 4 rhn-channel command in https://access.redhat.com/site/solutions/303323 and the error codes returned were 38, 39, 71, 71.

Did I do anything wrong?

Tri,

If the system is registered to RHN then atleast one channel you should be able to see using the below command i.e the base channel for rhel.

# rhn-channel -l

But if its not happening then might be somewhere its going wrong. So for quick assistance open a ticket with Red Hat Tech support with the following info.

- A sosreport from the system that you are trying to use as rhevm. Use "sosreport" command to get it.
- Screenshots of the error messages that you are getting when trying to register the system for the specific channels.

This process will help you to get the resolution faster.

Thanks,
Uday
 

Sorry for my confusing explaination. I do have this channel: rhel-x86_64-server-6. The error code 38 is because the machine has it already. I also get the Supplementary after I choose it in "Software Channel Subscriptions" section in customer portal.

About error code 71 when trying to add channel for rhevm and jbapp, the error says that "You do not have subscription permission to the designated channel. Please refer to your organization's channel or organization administrators for further details." I checked my account and I think I have full permission (Organization Administrator).

Tri,

So you have two channels now.

But I guess still you dont have access for the rhevm and jbossas channels for the account through which you are trying to access them. Either you checn with the "org admin" for the same or open a service request with the support team so that they can verify your account and suggest you accordingly !

BR,

Uday

I have opened a case for support team. Thanks for your help and I hope my problem will be solved.

Does anyone know if the trial now points to 3.2 (instead of 3.1)?  I thought I had heard that 3.2 is a separate channel.

Tri - there is a slight delay between the time when you submit the request and when it gets approved and when the channels are actually available.

Are you able to see the channels when you browse the RHEL 6 parent channel at RHN (http://access.redhat.com/) - it has been a while since I have done a trial - so, I'm a bit rusty ;-)

Thanks James, I hope that there's only a delay and the problem will be solved soon because I'm new to Red Hat and I'm afraid I couldn't setup in time.

Here are my channels:

http://imageshack.us/f/59/jlp.png/

http://imageshack.us/f/21/vhrx.png/

Still couldn't see RHEVM and jboss anywhere...

I tried reinstall the OS from 6.2 to 6.4. The error code 71 is still there when I use command line to add rhevm and jboss channel:

You do not have subscription permission to the designated channel. Please refer to your organization's channel or organization administrators for further details.

In RHN classic, rhevm and jboss channel are not there either.

I'm sorry if I cause inconvenience for you guys. I'm really desperate here.

No need to apologize.  If you re-installed the OS you probably need to remove the old system that was registered.  When you are logged in to the Customer Portal, mouse-over Subscriptions.  Your old host is either under Subscriptions | Active Subscriptions or RHN Classic | Registered Systems (I believe).  You need to find the instance from when you first installed the host and select and then chose delete profile.

 

Also, to be clear, you had went to:

http://www.redhat.com/promo/rhev3/tryrhev.html

and submitted the necessary information.  You then should have received an email stating you were approved.  That email should provide links to documentation and I believe the download of the product.  (sorry if you already acknowledged that you signed up for the eval and received the email - I can't see the rest of the thread while I am creating this response).

Thanks James.

Deleting the old system in RHN is the first thing I did before I reinstalled.

Following your suggestion, I filled in the form and the new option Additional Services Channels for Red Hat Enterprise Linux 6 for IA-32 - Red Hat JBoss EAP (v 6) for 6Server i386 appears. My application is being processed at the moment. Hope this works.

No worries Tri - I just wished there was more we (on the Customer Portal) could do.  The eval process is setup in a way that you don't need direct contact with Red Hat (which is nice if you are just looking but don't want to be bothered by Sales ;-)  I hope it gets resolved for you quickly.

Hey Tri - also make sure you have the correct architecture.  If there's a choice for x86-64, that may be the one you want.

- Greg

Ah, I've got the mails:

Your Red Hat subscription is now active

Your recently purchased subscription(s) listed below are now active and immediately accessible.  *Please save this information* for future reference or for additional purchases on this account.

Item Description     : 60 Day Supported Red Hat Enterprise Linux Server, (4 sockets) (Unlimited guests) Evaluation

Item Description     : Red Hat Enterprise Virtualization

Item Description     : 60 Day Supported Red Hat Enterprise Linux Server (8 sockets) (Unlimited guests) Evaluation

 

But sadly, Red Hat Virtualization Manager is still not there.

 

edit: omg, I was careless and installed the i386 of Red Hat 6.4. I'm going to download the x86_64 version again.

 

 

I reinstalled to 64 bit and yes, I installed rhevm successfully.

I'd like to thank all of you for helping me.

Great to hear, Tri. Let us know if you encounter any more issues.