USB devices menu option is not present in remote-viewer

Latest response

I read that there should be option in menu in remote-viewer which shows list of attached to desktop usb devices. But when I connect to virtual desktop and right-click on remote viewer frame - there's no such option (although, there are usb devices connected to my physical PC)r. I use Windows 7 as both client vdesktop, and  have usb redirection service installed on my physical PC. What might be wrong? Remote viewer version is 0.5.3 

 Thank you in advance for any help.

Responses

Dmitry,

Are you using RHEV 3.0 or 3.1 and do you have the virtual machine configured for native or legacy USB support?  If I remember correctly the right-click method to select USB devices to be redirected was a feature of the older SPICE client.  With remote viewer there's a USB device option under the file menu.

 Thank you for comment.

I'm using 3.1. And, you are right - there's a usb device option in file menu. But, it stays grey all the time - so, I thought, there might be some other option.

Do you, maybe, have any idea - why could that be? I tried incerting-ejecting flash drive, but it stayed grey anyway.

Do you have the virtual machine configured to use "native" usb redirection?  Also, I believe there's a usb service that needs to be running on your Windows client.  I can't remember the name of the service but it should have been installed when you installed remote-viewer.

Anthony, 

I tried to use both native and legacy modes. Results are quite interesting. When I use native (which I used when started this discussion) - there was no separate menu about USB devices, only a string in "File" menu (grayed out). 

Then I tried to use legacy mode - and I got a separate menu item "USB devices". And, it displays all connected usb devices. But still there's an issue in this mode. I can successfully work with general USB flash drive, but I cannot work with ikey1000 (smart card token). For ikey - the menu item is also grayed out, so, I cannot check it. I know that I need to install drivers on client machine for this - and I did that, so, this ikey is being successfully recognized by client OS. 

Do you have any ideas, where in the logs could I find some hints on why this is happening?