from where to download RHEV-M and how to install

Latest response

Hi all,


i have installed RHEL 6.4 in a server. Now i want to configure RHEV-Manager on that. How to do that?

Do i need to download any package, if yes, then please get me the Link. If no, then how can i proceed further.


Thanks in advance for the help.


Warm regards,



You need to request an eval (which is quite simple)


Also - you should follow the eval guide, it will bring  you up to speed very quickly.

Link to all RHEV documentation

The RHEV Installation Guide does a great job at describing the installation process.

A brief summary is:

1) Add the appropriate RHN channels

2) yum update

3) yum install rhevm

4) rhevm-setup

In order to follow the Installation Guide your system needs to have the appropriate RHN channels added.

Agreed - although it may be possible to get around having RHN, it is most likely not worth the additional effort you have to invest.

The evaluation that Red Hat offers is free and should provide everything you need to be successful.

Thanks for the information, but adding to the  RHN is must or not.

I have now added the server to RHN, but while trying to execute the command : "yum upgrade".. it shows the error repository not found.


Need help.

What is the output of the command "rhn-channel --list"


Thanks for the information, but adding to the  RHN is must or not.

I have now added the server to RHN, but while trying to execute the command : "yum upgrade".. it shows the error repository not found, though it is created as per the installation manual.


Need help.


# rhn-channel --add --channel=rhel-x86_64-server-6-rhevm -3
# rhn-channel --add --channel=jbappplatform -5-x86_64-server-6-rpm
# rhn-channel --add --channel=rhel-x86_64-server-supplementary-6
# rhn-channel --add --channel=jbappplatform -5-x86_64-server-6-rpm
# rhn-channel --add --channel=rhel-x86_64-server-supplem entary-6
# rhn-channel --add --channel=rhel-x86_64-server-supplem entary-6# rhn-channel --add --channel=rhel-x86_64-server-6-rhevm -3
# rhn-channel --add --channel=jbappplatform -5-x86_64-server-6-rpm
# rhn-channel --add --channel=rhel-x86_64-server-supplem entary-6

Are you trying to install RHEV 3.1 or 3.0?  The JBoss and RHEV-M channels you have listed are for RHEV 3.0.

If you're looking for RHEV 3.1 the following Installation Guide has the rhn-channel commands you need:

Does running "yum list available" show available packages from rhel and rhev repositories? If not, then you should check to see if you have lost your network connection to Red Hat Network.

thanks for the info.. Actually i was trying to install RHEV3.1 but was following the 3.0 installation guide. Now i have installed it  successfully.


Thanks a lot :)

Thanks all for the help, as i was able to install the manager but now i face login problem through client.


Dear All,


I have installed and configured the RHEV-M, and now trying to login through the client "". I get the login screen with user name, password and Domain:Intenal. But after entering the credential, the login is keep on proccessing . From last two hours the logging screen is proccessing, but not getting logged in. It is not showing any error regarding the credentials.



What might be the problem.


Please help me ASAP.


Thanks & Regards,


Hi Somnath,

I think you have configured RHEV3.1.  Can you try resetting the password with following command from RHEVM server:


# rhevm-config -s AdminPassword=interactive




After restting the password, restart the "ovrit-engine" service.


# /etc/init.d/ovirt-engine restart

Then check if you are able to login.



thanks Prateek for the help. I was abled to logged in.


Now i am facing a different issue regarding CONSOLE of VMs.

While creating the VM, i have selected console:Spice, and the operating system to be installed: win7.

But if i right click on any virtual machine, i see the console option is blurred.

Please find out the attached screen shot for better idea of problem.

Please suggest me what could be the problem and solutions accordingly.


Thanks in advance.


That probably means you don't have the Spice client installed. If your client (the physical machine you're connecting from) is RHEL 6, use Firefox and install the Firefox plugin via yum. If your client is Windows, *you need to use IE* as the Windows Spice plugin is ActiveX. 

Refer to this documentation. For some reason this isn't mentioned in the installation or administration docs; you have to look at the user portal docs: