start VINO at boot

Latest response

I need to give remote assistance to my users, I need to let them watch what i do on their computers.

I wish to use free software (I heard about Real VNC but i know it must be paid for business)

I need that VINO is started at boot time, before user login, in order to allow me to see the login prompt, and choose to login as user1 or user2.

Local users must watch what I do on their computers.

I tried vnc-server but i've seen that windows opened on remote connection are not shown on local display. Moreover, with vnc-server I couldn't setup a remote login before a user was logged in.

For these reasons i suppose VINO should be the right solution. Did I said something wrong? Do you know how to setup VINO for this purpose?

Thank you.

Responses

Hi Allesandro. Sorry the community hasn't been able to help out with either of your VINO questions yet. I'm reaching out to some folks here who may be able to assist.

Hello Allesandro,

You are right in understanding that Vino is the right solution for what you want to achieve. Although tiger-vnc is free software, it starts a remote login session, since the solution is to cater to multi user remote sessions like Red Hat Enterprise Linux is capable of doing.

Since your primary goal is to be able to share your desktop with other users, Vino is the way to go. Setting up Vino is pretty straight forward.

First, from your Red Hat Enterprise Linux desktop, click on the System->Preferences->Remote Desktop menu item to launch the "Remote Desktop Preferences" window. This can also be started from the 'gnome-terminal' by running the 'vino-preferences' command. Once the preferences window is launched, in the "Sharing" section, select the "Allow other users to view your desktop" option. This will immediatly start the Vino session for your user. You can further chose if you want any Security options for the remote access session (under the Security section). You can close the window once you have made your choices.

 

Now launch the "Startup Preferences" window from System->Preferences->Startup Applications.  And under the 'Startup Programs' tab, you should find the "Remote Desktop" service. Make sure that it is enabled. This option will make sure that vino is started as soon as you login to your session.

Once this is done. You can access your desktop session by using 'vncviewer' (or any vnc client) and connection to your machine's ipaddress/hostname:0, like this:

 $ vncview testmachine:0

 

You should be up and going.

 

Hope that helps.

Cheers,

..Partha

Thank you Partha,

but as I worte on my first post "I need that VINO is started at boot time, before user login, in order to allow me to see the login prompt, and choose to login as user1 or user2".

This is needed because it is supposed that in some cases there is no operator on the computer site.

Yur solution doesn't solve my problem since vino server is started only if the local operator login on the computer with its username.

I tried the following solution in order to enable vnc-server at boot time, but i can't make it work:

https://access.redhat.com/knowledge/solutions/7096

I found that tigervnc-server was still installed and tigervnc-server-module was not present on my dvd.

Then i downloaded and installed the following package: tigervnc-server-module-1.0.90-0.17.20110314svn4359.el6.x86_64.rpm

(my RHEL desktop has version 6.2 64 bit)

with vncpasswd i setted a password for vnc

(the firewall is disabled)

I edited my xorg.conf as detailed on the linked guide.

Then i rebooted my pc but the vncclient (on a LAN pc) is not able to connect to my RHEL workstation. Note that the host with vncclient has nothing to do with this problem cause I can connect without problems if i enable vino.

Where is the problem? which check i can do? Do i have to enable the service vnc-server?

 

Here it is my xorg.conf file:

Section "ServerLayout"
 Identifier     "X.org Configured"
 Screen      0  "Screen0" 0 0
 InputDevice    "Mouse0" "CorePointer"
 InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
 ModulePath   "/usr/lib64/xorg/modules"
 FontPath     "catalogue:/etc/X11/fontpath.d"
 FontPath     "built-ins"
EndSection

Section "Module"
 Load  "glx"
 Load  "extmod"
 Load  "dbe"
 Load  "dri"
 Load  "dri2"
 Load  "record"
 Load  "vnc"
EndSection

Section "InputDevice"
 Identifier  "Keyboard0"
 Driver      "kbd"
EndSection

Section "InputDevice"
 Identifier  "Mouse0"
 Driver      "mouse"
 Option     "Protocol" "auto"
 Option     "Device" "/dev/input/mice"
 Option     "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 Identifier   "Monitor0"
 VendorName   "Monitor Vendor"
 ModelName    "Monitor Model"
EndSection

Section "Monitor"
 Identifier   "Monitor1"
 VendorName   "Monitor Vendor"
 ModelName    "Monitor Model"
EndSection

Section "Monitor"
 Identifier   "Monitor2"
 VendorName   "Monitor Vendor"
 ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "DRI"                 # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "VideoKey"            # <i>
        #Option     "FallbackDebug"       # [<bool>]
        #Option     "Tiling"              # [<bool>]
        #Option     "LinearFramebuffer"   # [<bool>]
        #Option     "Shadow"              # [<bool>]
        #Option     "SwapbuffersWait"     # [<bool>]
        #Option     "TripleBuffer"        # [<bool>]
        #Option     "XvMC"                # [<bool>]
        #Option     "XvPreferOverlay"     # [<bool>]
        #Option     "DebugFlushBatches"   # [<bool>]
        #Option     "DebugFlushCaches"    # [<bool>]
        #Option     "DebugWait"           # [<bool>]
        #Option     "HotPlug"             # [<bool>]
        #Option     "RelaxedFencing"      # [<bool>]
 Identifier  "Card0"
 Driver      "intel"
 BusID       "PCI:0:2:0"
EndSection

Section "Screen"
 Identifier "Screen0"
 Device     "Card0"
 Monitor    "Monitor0"
 SubSection "Display"
  Viewport   0 0
  Depth     1
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     4
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     8
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     15
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     16
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     24
 EndSubSection
 Option "passwordFile" "/root/.vnc/passwd"
EndSection

 

 

 

I formatted my computer, reinstalled operative system (RHEL 6.2 64 bit) and retried the linked guide (see my previous post).

Now the vnc works as expected. I can log in from remote. The vnc server starts listening as soon as the computer boots.

Solved!

Great to hear you got this issue fixed.