No modem present

Latest response

How do I get RHEL 5u5 to recognize that there is a NIC available?

Just installed RHEL 5u5 (because our sofware requires it) on a Dell Latitude E6520 laptop and I was never prompted for the network information.  The installation skipped right over that part.  We have to statically set our NIC parameters, IP address and host name.  We do not use IPv6, only IPv4.

On boot up (when F12 selecting for the boot device) the Internal NIC is listed as an available boot device. 

NIC lights up when cable is plugged in.  Previous windows installation saw and installed the NIC for the network (this was one of several tests to make sure the NIC was good).

Downloaded the 5u5 driver update.  Will that fix the problem I am having?

 Our network is a closed network so I cannot do an update from RedHat.  There is no connection to the outside. So we have to do any updates from disc.  We have never had this problem before so no upodate was or has ever been needed, until now (maybe).

David

Responses

It sounds as if anaconda did not find a matching module for the hardware so the installer skipped network configuraiton.  Do you see any adapter in Network Manager or the output of ifconfig?  Do you know what type of NIC adapter, can you provide output of # lspci |grep -i net and # dmesg |grep -i net

Here is the term window output.  My work browser will not let me send picture snapshots but I have those also for the Network Manager if you have an alternate email I can send to (I am replying on the RedHat website).  The scree shot does not list any hardware or configuration information. It is all blank.

[root@jcats-ws-155 ~]# ifconfig -a
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2242 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2242 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2008413 (1.9 MiB)  TX bytes:2008413 (1.9 MiB)

sit0      Link encap:IPv6-in-IPv4 
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

[root@jcats-ws-155 ~]# lspci |grep -i net
00:19.0 Ethernet controller: Intel Corporation Unknown device 1502 (rev 04)
03:00.0 Network controller: Intel Corporation Unknown device 0082 (rev 34)
[root@jcats-ws-155 ~]# dmesg |grep -i net
NET: Registered protocol family 16
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
NET: Registered protocol family 2
audit: initializing netlink socket (disabled)
SELinux:  Registering netfilter hooks
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Initalizing network drop monitor service
SELinux:  Unregistering netfilter hooks
NET: Registered protocol family 10
NET: Registered protocol family 31
[root@jcats-ws-155 ~]#

From /usr/share/hwdata/pci.ids looks like an Intel device : 

1502  82579LM Gigabit Network Connection
0082  Centrino Advanced-N 6205

Try adding the e1000e module: 
# modprobe e1000
# modprobe e1000e
# depmod -a
 
Reboot.  See if your nic is now properly recognized.