Linux 2.6.32-279.14.1.el6.x86_64 and samba-3.5.10-125.el6.x86_64 NT_STATUS_ACCESS_DENIED

Latest response

Hi,

1. The first authentication with „security = domain“ is working if I try to access a samba share

[2013/01/02 09:22:12.658060, 2] smbd/sesssetup.c:1413(setup_new_vc_session) setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old resources.

[2013/01/02 09:22:12.661227, 2] smbd/sesssetup.c:1413(setup_new_vc_session) setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old resources.

[2013/01/02 09:22:12.709683, 2] auth/auth.c:304(check_ntlm_password) check_ntlm_password: authentication for user [ext.mis] -> [ext.mis] -> [ext.mis] succeeded

[2013/01/02 09:22:17.177831, 1] smbd/service.c:1070(make_connection_snum) pc-etw-051 (::ffff:172.28.96.114) connect to service vbs-1 initially as user ext.mis (uid=589, gid=1000) (pid 6776)

[2013/01/02 09:22:17.196738, 1] smbd/service.c:1251(close_cnum) pc-etw-051 (::ffff:172.28.96.114) closed connection to service vbs-1 2. And now the problem starts: the user authentication goes lost and I am working as “guest” on the samba share:

[2013/01/02 09:22:17.199507, 2] smbd/service.c:587(create_connection_server_info) guest user (from session setup) not permitted to access this share (vbs-1)

[2013/01/02 09:22:17.199565, 1] smbd/service.c:678(make_connection_snum) create_connection_server_info failed: NT_STATUS_ACCESS_DENIED

[2013/01/02 09:22:17.238985, 1] smbd/service.c:1070(make_connection_snum) pc-etw-051 (::ffff:172.28.96.114) connect to service vbs-1 initially as user ext.mis (uid=589, gid=1000) (pid 6776)

[2013/01/02 09:22:21.024095, 2] smbd/service.c:587(create_connection_server_info) guest user (from session setup) not permitted to access this share (vbs-1) [2013/01/02 09:22:21.024194, 1] smbd/service.c:678(make_connection_snum) create_connection_server_info failed: NT_STATUS_ACCESS_DENIED

[2013/01/02 09:22:21.029157, 2] smbd/service.c:587(create_connection_server_info) guest user (from session setup) not permitted to access this share (vbs-1)

[2013/01/02 09:22:21.029254, 1] smbd/service.c:678(make_connection_snum) create_connection_server_info failed: NT_STATUS_ACCESS_DENIED

Group, permission etc is ok. We are working on Linux 2.6.32-279.14.1.el6.x86_64 and samba-3.5.10-125.el6.x86_64.

What is the reason for samba to loose the authentication ?

Please let me know.

Thanks Michael

Responses

samba is running in domain mode.  This mode can cause issues for newer windows systems. A proper setup will use active directory mode.
security = ADS

Could you try to configure as explained in https://access.redhat.com/knowledge/solutions/43065 & check if isue persists. This kbase is for Microsoft Windows Server 2003 Active Directory but it is known to work with Microsoft Windows Server 2008 Active Directory