Error installing postgres9.2 (libuuid.so.16)

Latest response

Im trying to install postgres 9.2 on rhel6.1 and it gives me the error postgres92-9.2.1-1.x86_64 requires libuuid.so.16()(64bit). I am trying to install offline to our internal server. How do I get the libuuid.so.16 where it will be found so it will install?

Responses

Red Hat does not ship PostgreSQL 9.2 currently; cf. When will Red Hat support postgresql 9.x ?

and the .so version of RHEL6's libuuid is 1.3, not 16. Youre best chance at getting your question answered will be to ask the vendor/organisation/developer you obtained the postgres92-9.2.1-1.x86_64 package from.

 

Alternatively, you could try the binaries from the upstream PostgreSQL community (http://yum.postgresql.org/); they appear to supply complete repositories, providing not just PostgreSQL itself but also any additional packages required to use them on RHEL (and several other Linux distributions).