Kernel Panic During Boot-Enterprise WS 6.3-x86_64

Latest response

I am trying to install Enterprise Workstation 6.3-x86_64 on a HP Compaq 6300 PC. I'm not putting the Linux install on its internal SATA HD (which is partitioned for Windows 7), but rather on an external USB 3.0 Lacie hard drive (plugged into a USB 3.0 port). I downloaded the 6.3 DVD iso, created an install DVD, and set up the OS on the Lacie drive using anaconda. So far, so good.

 

When I boot up the Lacie, the Redhat 6 splash screen comes up and it starts the boot process (I can escape into grub if I want). Then I get a kernel panic:

 

Kernel panic - not syncing: Attempted to kill init!

Fid: 1, comm: init Not tainted 2.6.32-279.e16.x86_64 #1

 

[trace stuff follows]

 

panic occurred, switching back to text console.

 

At this point the system hangs and I have to recycle power.

 

I assume that the system got into init phase, and then encountered a problem.

 

I have downloaded the DVD iso a second time, tested the DVD prior to installing to the USB drive with the same result, so I don't think it's a bad download.

 

Any suggestions would be appreciated.

Responses

When the splash screen comes up, intervene and edit the "kernel" line-- remove the "quiet" keyword then boot from that revised line.  You'll probably be able see what's happening just before the panic.

I believe you will need to recompile your initrd to include the USB functionality in your initrd.img

Specifically mkinitrd --preload ehci-hcd --preload usb-storage --preload scsi_mod --preload sd_mod /boot/<blah>

 

I imagine that the installer is able to see your USB drive during the install as it would need the USB capability at that point for external USB DVD drives, or boot from a flash drive, etc...

 

The sources I am finding appear quite a bit older and perhaps someone else knows whether the new(er) releases would have this capability built in to the "standard" initrd image.  

 

Are you using slices (parititions) or LVM during your install?  Is your laptop UEFI capable?

Thanks to both for useful suggestions/questions. Prior to the kernel panic, the following messages appear:

 

dracut Warning: LVM vg_kepler/lv_root not found

dracut Warning: LVM vg_kepler/lv_swap not found

 

dracut Warning Boot has failed. To debug this issue [...]

 

So it must be that LVM is assumed but not implemented in the install.

 

The LaCie hard disk is not partitioned -- I have let the intall process format the entire disk (500 MB). I don't recall an option to specify LVM or not.

 

The BIOS is UEFI capable.

This appears to be a USB 3.0 driver problem. When I plug the external drive (LaCie) into a USB 2.0 port, the system boots up normally. Don't know exactly how to incorporate the proper USB 3.0 driver, though. I assume that this involves a rebuild somewhere.

Thanks for the update Bruce (it's good to know that USB boot is supported).  I found a somewhat related thread mentioning 'xhci_hcd'

https://access.redhat.com/knowledge/articles/55130

 

I have no way of validating that this is valid, but you could try adding the following to your boot string during boot up:

xhci_hcd.enable=1

 

So - the example on my Lenovo is I had to add the i8042.noloop to prevent some crazy mouse/screen lockup issue I was having.

 

[root@neo ~]# cat /proc/cmdline

ro root=/dev/mapper/vg_neo-lv_root rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16 rhgb crashkernel=128M rd_LVM_LV=vg_neo/lv_swap  KEYBOARD TYPE=pc KEYTABLE=us rd_LVM_LV=vg_neo/lv_root rd_NO_DM i8042.noloop

 

Again - thanks for the update.  This may become more of a relevant issue as USB3 becomes more prevalent (if USB3 is indeed to blame).

> So it must be that LVM is assumed but not implemented in the install.

 

It is assumed in this case because the LVM structures named in the "rd_LVM_LV" options are considered mandatory by dracut.  It aborts if it cannot find them, even if they play no part in the actual boot process.

Thanks for the additional suggestions, James. Unfortunately, adding xhci_hcd.enable=1 to the boot string had no effect. One of my RHEL-savvy colleagues had another suggestion, which I will pursue when I have time. I am content to use the USB 2.0 connection for the moment since I'm just getting the system setup and am not doing any disk-intensive stuff. But I will report any solution that I come up with.

https://access.redhat.com/knowledge/articles/55130

added your question.

Thanks, I appreciate that.

Hello Bruce & Jan,

It turns out the Article 55130 is a duplicate of a more complete Solution here: https://access.redhat.com/knowledge/solutions/42570

42570 links to a Solution titled "Does RHEL 6 support USB 3.0 devices at boot?" located here: https://access.redhat.com/knowledge/solutions/46803

I've modified 46803 to include the question Jan asked, so hopefully it will be easier to find in the future. Additionally I'm going to remove the Article 55130 since it's out of date and not as visible as the others.

Bruce, please let us know if you try the resolution in 46803 and if it works for you!