Power Management on IBM Bladecentre

Latest response

I get the following error when configuring power management on IBM bladecentre - same error if I use incorrect credentials so looks like a problem in RHEV, not on the blade centre. Worked OK in 3.0

 

"Test Failed, Host Status is: unknown. The fence-agent script reported the following error: Failed: You have to enter plug number Please use '-h' for usage"

Responses

Seems like a known issue already fixed upstream, so it should also make it into RHEV 3.1 beta in one of the upcoming builds.

 

Can you post a relevant log snippet, from engine.log on RHEV-M and from vdsm.log on the fencing proxy host?

I couldn't see anything in the vdsm.log, here's the snippet from engine.log

 

2012-09-05 07:38:29,125 INFO  [org.ovirt.engine.core.bll.FencingExecutor] (ajp-/127.0.0.1:8009-6) Executing <Status> Power Management command, Proxy Host:koguxxd51, Agent:bladecenter, Target Host:, Management IP:kogbc05.stgeorge.com.au, User:powermgt, Options:port=22,secure=true
2012-09-05 07:38:29,143 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (ajp-/127.0.0.1:8009-6) START, FenceVdsVDSCommand(vdsId = 757298c8-f583-11e1-91a4-525400ced640, targetVdsId = f450b23e-f582-11e1-b1c6-525400ced640, action = Status, ip = kogbc05.stgeorge.com.au, port = , type = bladecenter, user = powermgt, password = ******, options = 'port=22,secure=true'), log id: 3fc7f79a
2012-09-05 07:38:29,271 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (ajp-/127.0.0.1:8009-6) FINISH, FenceVdsVDSCommand, return: Test Failed, Host Status is: unknown. The fence-agent script reported the following error: Failed: You have to enter plug number
Please use '-h' for usage
, log id: 3fc7f79a
 

OK, just to confirm, this is work in progress at the moment. Thanks for reporting