RHEVM : Update from 3.0 to 3.1beta failing

Latest response

Hi

 

Running "/usr/bin/rhevm-upgrade" on 3.0 recognises that a newer "rhevm-setup" package is available and asks you to update it using regular yum update (i.e. yum update rhevm-setup)

 

Then running the updated "/usr/bin/rhevm-upgrade" tool fails and returns a code which errors with :-

 

Error: JBoss service is dead, but pid file exists
Error: Upgrade failed.

 

This appears to be because it is attempting to check the status of "ovirt-engine" service instead of jbossas.

 

The rhevm-upgrade tool is part of 3.1beta package :-  rhevm-setup-3.1.0-11.el6ev.noarch
 

Am I wrongly assumimg you can update from 3.0 to 3.1beta ?

 

Thanks

Responses

Hi Richard,

 

there is no official upgrade path form 3.0 to 3.1beta. Judging from a number of changes (the db name has changed, f.e.), I don't think it will be available anytime soon. But I would very much like to be mistaken :)

 

Cheers

 

Stanislav

 

There is no upgrade path between 3.0 and 3.1beta, if you wan tto try the beta, you need to set up a new setup

But we will be able to update from 3.0 to 3.1 final release, right ?

Absolutely. Because of the numerous changes in the RHEV-Manager, it might come with a special tool for upgrade, keep tuned :)

Will do , thanks.