tftp server

Latest response

Having a problem trying to load a tftp server on my linux box.
did a fresh install using YUM.

[root@localhost ~]# yum install tftp-server
[root@localhost ~]# yum install tftp

three things were installed tftp-server, tftp and xinetd.x86_64.
Once I changed the tag in the file:

/etc/xinetd.d/tftp
disable = no

After restarting xined service I can not do a get with tftp, instead I get the following.
[root@localhost ~]# tftp -vvv localhost -c get me
Connected to localhost (::1), port 69
getting from localhost:me to me [netascii]
Transfer timed out.

both iptables adn ip6tables are disabled, has anyone seen this before?

Responses

It looks like tftp is resolving localhost to the IPv6 address for localhost (::1). If you don't mean to use IPv6 networking, you can comment out the line beginning with ::1 in the /etc/hosts file. Or, just try using 127.0.0.1 instead of localhost for your tftp command.

 

Other things that could block access to the tftp service are denials in the /etc/hosts.allow or /etc/hosts.deny files that are associated with xinetd. An ALL: ALL in the /etc/hosts.deny file, without having explicitly allowed xinetd, will prevent access to the tftp server.

We created a KCS solution that we believe addresses this problem (https://access.redhat.com/knowledge/solutions/196883). This issue could come up any time someone tries to use localhost to reach the local system when IPv6 networking is not enabled.