Unable to edit a template via Admin portal as admin but able to via User portal as PowerUser

Latest response



Any one else experienced this little gem ?

I'm wondering if its because I have a special character in my datacentre and cluster names ?


From my case 00679200 :-


Expected :- Ability to edit a template via the Admin portal as admin user and via User portal as PowerUser


Actual :- We are unable to edit a template via the Admin portal as admin user but are able to via the User portal as a PowerUser


Version :- RHEVM 3.0.3-0001-3.


Further detail :- When logged into the Admin portal as user "admin" and domain "internal" we are unable to edit any details of an existing template. The "Edit Template" box appears and we are allowed to make changes to certain fields within it but changes are rejected because it complains that the "Host Cluster" field is empty. This is a drop down field but has no items to select from. However, we are able to edit and apply changes to the template without any issues via the User portal as a PowerUser.


I am able to supply screen dumps if required.






If you just Edit the template and press OK without making any change, are you getting the same error?


Did you try the tech preview webadmin portal for testing?

Hi Richard,


Screen dumps would be helpful indeed. I'd also like to know whether you're getting the reject message in both webadmin and the WPF GUI


You mentioned a special char in the DC and Cluster names, what is it exactly? I will need as much data as possible in order to try and reproduve this issue internally





Yes - Basically its expecting a "Host Cluster" but the field is not populated and there's nothing to select from in the drop down.  Secondly, it complains because the template has no name in the field "Name". I would expect that to be populated from the template your are editing , as it does when editing via the User portal.


No, I've not tried the tech preview portal but I'll give it a go if you feel it might be fixed there.



Hi Dan


I shall post some screen dumps as soon as I can.

In the meantime, my datacentre name is Governors_House and cluster name is PGDS_PreProd


Please excuse my ignorance but what is meant by WPF GUI ?





Bit difficult to see, so I'll mail you the full size versions.

WPF is the IE/dotnet based olg admin GUI. The one you get to when you go to http://RHEV-M:8080/RHEVManager

Hmm, on my 3.0.5 setup, I just set up a new DC called Test_DC, with a cluster called Test_Cluster, created a small VM (test_vm) and made a test_template out of it. Then I tried to edit it which worked nicely


Maybe if I give the template the long name you are using... Can you paste it here so I try?






If any use, additional screen shots and sosreport have been uploaded to case 00679200.

BTW - I have a test RHEV environment based on 3.0.2_0001 and it has the same issue.


You want me to try updating to 3.0.5 ?

Tried to rename my test template to both of these and then could easily edit it. 

Can you try this in the webadmin? just go to https://yourRHEV-M:8443/webadmin


Upgrade is recommended in any case :)



Sussed it.

I tried via the webadmin portal (didn't know it existed!) on my 3.0.3 RHEVM and I get exactly the same result as via the Admin portal. Could this be a IE browser issue?"

Tried the webadmin portal via Firefox on my trusty RHEL6 desktop and... bingo-bango !


Mauled by IE...again.    (IE

Hell , they have a lot to answer for.


I'll update the support ticket and leave you alone now.




So, via IE, in both types of the Admin portal, you see this error? 


Can you just make sure you update this thread once you're on 3.0.5, so we know whether the update will resolve it?

I'd also try from another windows workstation with, possibly, another version of IE in place, just to gather some extra info on the issue

The update to 3.0.5 didn't help.

Tried a different desktop with the same IE version. Same result. 

Starting to think this issue is down to something in specific within our environment.

Could be, but before you waste too much time investigating, do keep in mind we are moving towards getting rid of the .net portal, so IE will stop being required

Yep. All the better too.

However, remember that editing a template via the new webadmin portal using IE doesn't work either.

Only via the User portal does it work.   This might be a problem for those of use "forced" to use IE.

The reality is that we're not often going to have the need to edit a template.

I'll just add this to the list of reason why we should move to a non IE browser ;)

While you are of course right, I still couldn't reproduce the issue locally, so this is either something very uncommon, or has something to do with your specific environment



I thought I was going mad when my ability to edit a template came back only to then dissapeared later.

It would seem that the issue is related to where you attempt to edit rather than how or the browser type.


From the Tree :-

Editing is allowed from the "System" --> "Templates"

Editing is not allowed from "Datacentre" --> "Templates"


Perhaps an admin user permission is not being properly cascaded to the Datacentres as they are created ?

Just tried it here:

in the tree selected "system", on the righthand side selected Templates, find template and edit - works

in the tree selected a DC, under that "Templates", switch to the righthand side, select template and edit - works


Am I missing something here?

Dan,  I concur.

But try this :-


In the tree, select choose a DC, remain in the tree and under you DC you will see "Templates", select (highlight) a template and the "Edit" button will be unghosted along with "Remove", "Export" and "Copy" , hit the "Edit" button.

(see my first screen shot for clarity)


What d'ya get ?

Right you are, I closed the window as soon as I saw it was opening ok, but didn't really scan it. Looks like a GUI bug, can you post this in a case please?

Jolly good.  Case ref  00679200 updated.

I've charged Nikhil Gupta with the task of pushing this upstream.


Thanks again.