REHL 6.2 problem installing gcc/g++ compilers: lib error

Latest response

 

Hello everyone,

 

I need help!

 

I am new to Linux install (finally realizing that having an IT group was so helpful!)

 

Like many other I also need the g++ compiler to install other packages (NVIDIA drivers).

 

I follow your intruction , used yum whatprovides "*/g++" to find the name of the package and used:

 

yum install gcc-c++-4.4.5-6.el6.x86_64 to install the package.

 

But I ran into an error:

 

"Error: Package: libstdc++-devel-4.4.5-6.el6.x86_64 (rhel-x86_64-workstation-6)
           Requires: libstdc++(x86-64) = 4.4.5-6.el6
           Installed: libstdc++-4.4.6-3.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201111171049.x86_64/6.2)
               libstdc++(x86-64) = 4.4.6-3.el6
           Available: libstdc++-4.4.4-13.el6.x86_64 (rhel-x86_64-workstation-6)
               libstdc++(x86-64) = 4.4.4-13.el6
           Available: libstdc++-4.4.5-6.el6.x86_64 (rhel-x86_64-workstation-6)
               libstdc++(x86-64) = 4.4.5-6.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 

 

I tied to install the package for the library , did not work, and I check I had the devtool-set v1.0 and it is already install.

 

Thank you in advance for your help!

Responses

OK,

It took me almost a day but I found the issues. I hope it will help other novice like me with the same issue.

 

1st I had to unplugged a USB component (NVIDIA 3D box)

 

The lib problem disappeared!.

Obviously other problem appeared:

Other lib where missing libmpc.so.2()

 

I solved that by downloading lbmpc-0.8-3.el6.x86_64.rpm

 

Finally I was able to install the gcc/g++ compiler.

 

Since I did all f that to install the NVIDIA drivers, that was not enough.

I ran into a kernel version issue. You need to install the kernel-devel package (kernel source are needed to compile the NVIDIA drivers).

I used "yum install kernel-devel"

 

Once done you need to install the NVIDIA package with this comment:

sh NVIDIA-Linux-x86_64-295.59.run --kernel-name='2.6.32-220.17.1.el6.x86_64"

 

And miracle it got installed!

 

Hi Eric,

 

Thank you for this information as it helped me to install my Nvidia Geforce 210 card on my server. The only change I made was this:

 

sh NVIDIA-Linux-x86_64-yourversion --kernel-source-path="/usr/src/kernels/2.6.32-279.5.2.el6.x86_64"

 

I assume this was slightly different because im running RHEL6.3

 

 

I used these instructions to do the entire installation plus yours to get it to work: http://www.twodee.org/weblog/?p=1056

 

Thanks,

Justin Bolin

Justin,

Glad to see this discussion helped you out! And thanks for providing some additional resources. Don't forget to reward community contributors like Eric with votes and positive ratings!