RHEV-H bootable USB install goes straight to cli Login Prompt.

Latest response

Hi, I have created a usb boot device using command:


dd if=/usr/share/rhev-hypervisor/rhev-hypervisor.iso of=/dev/sdb1

Which resulted in a bootable usb. However after selecting the "Install or Upgrade" option, I am delivered straight to a login prompt even though I have not installed the hypervisor, and have not been given any opportunity to create a root password. I thought perhaps the root password is inherited from the RHEV-Manager machine I used to create the bootable usb but this does not work either.


I've been working off this page:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.0/html-single/Installation_Guide/index.html#sect-Installation_Guide-Installing_the_PRODUCT_Hypervisor (@ 7.1)


Any advise appretiated


Hi Piotr,


I just tried this with the image from rhev-hypervisor6-6.2-20120423.1.el6, and it works for me.  A couple things you can try:


For your of= device, use the base device /dev/sdb instead of a partition /dev/sdb1.  Another option is to install the rhev-hypervisor-tools package and run rhevh-iso-to-disk to setup the usb instead.


rhevh-iso-to-disk --format --reset-mbr /usr/share/rhev-hypervisor /dev/sdb



Hi Michael,


There seems to be something wrong...


[root@rhevmanager]# rhevh-iso-to-disk --format --reset-mbr /usr/share/rhev-hypervisor /dev/sdb1

/usr/bin/rhevh-iso-to-disk [--format] [--reset-mbr] [--noverify] [--overlay-size-mb <size>] [--home-size-mb <size>] [--unencrypted-home] [--skipcopy] <isopath> <usbstick device>



it looks ok syntax wise as far as i can see. Your other suggestion (sdb instead of sdb1) resulted in the same error by the way.

Oh, sorry, that's my fault.  /usr/share/rhev-hypervisor/rhev-hypervisor.iso


 rhevh-iso-to-disk --format --reset-mbr /usr/share/rhev-hypervisor/rhev-hypervisor.iso /dev/sdb


Now I get this error re Syslinux:


[root@rhevmanager]# rhevh-iso-to-disk --format --reset-mbr /usr/share/rhev-hypervisor/rhevh-latest-6.iso /dev/sdb
Verifying image...
/usr/share/rhev-hypervisor/rhevh-6.2-20120510.0.el6_2.iso: 3fa33afa4b892dbade72041e7ca26467
Fragment sums: 97c2f5c36b6f4814eda5548e9171cacc524eb7f5d751d5e23ed4bc2c65cf
Fragment count: 20
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.
Press Enter to continue or ctrl-c to abort

Warning: The resulting partition is not properly aligned for best performance.
Waiting for devices to settle...
mkdosfs 3.0.9 (31 Jan 2010)
You need to have syslinux installed to run this script


There it stops. there seems to be nothing on the internet about installing Syslinux for RHEL and similar. From what I can gather it's for use with Windows machines, not sure why the RHEL manager I am using to create this RHEVH bootable usb is complaining about not being able to run the script because it doesn't have something for Windows. :-/


Many thanks again.

'yum install syslinux' should install that on your RHEL host.  I believe it's in the normal RHEL 6 base channel on RHN.


Has there been anything installed on the RHEV-H host before?  Can you try cleaning the disks if there has?  You can boot with "storage_init=/dev/sda uninstall" on the command line to wipe the /dev/sda device.



I had tried yum -y install syslinux but was getting this:


Downloading Packages:
https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os/Packages/syslinux-4.02-4.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403"
Trying other mirror.

Error Downloading Packages:
syslinux-4.02-4.el6.x86_64: failure: Packages/syslinux-4.02-4.el6.x86_64.rpm from rhel-6-server-rpms: [Errno 256] No more mirrors to try.


Looks like I need to edit the file /etc/yum.repos.d/redhat.repo, which if you're interested currently looks like this: http://pastebin.com/s23Skc20


I also get the same error when I just try to update yum (yum -update). I will try pushing updates from rhn and see if that fixes anything.

Ok, I edited out an 'enabled' line from the Redhat repo and this enabled me to run yum -update and then yum -install syslinux. I've now been able to create the bootable rhevh usb and begin installation.


thanks for the help and assistance!