Rescan iSCSI

Latest response

Hello,

   I have not gone in to production mode as I am still trying to test everything. I came from a VMWare world where features were a little more rich so I'm still a bit whiney! No complaints though, I love Linux ;)

 

 I am creating several LUNS on my iSCSI unit, which worked fine, I could see them and use them. . . until I deleted one and had a VM on it. The only way to destroy it was to destroy the entire data center and recreate it.

 

 Ok so I'm starting over.. just playing around before I create a VM again, I created some LUN's and I'm able to see them. Now... I went and deleted some of those LUNS and created another one. I still see all the old LUN's and don't see the new one. The old ones are orange and have an explamation mark.

 

I tried putting a host in maintenance mode and then restarting it, but now I see no LUNS even though if I go to the host and issue fdisk -l I can see that it can see volumes.

 

RHEV 3.0

 

Thanks!

Responses

Right, in RHEV, there is a right way of doing things, and if you want to remove an object, it's easiest and safest to do that from within RHEV. Storage Domains need to be removed, not erased on the SAN side, leaving RHEV with no indications as to what happened.

Having said that, there's an emergency option in case an SD is gone and there isn't much one can do about it called "Destroy" - this will remove the SD from the database, never attempting to actually go and clear the LUNs. Be careful with this one and use it only if you're out of options.

 

 

About the new LUNs, I'm getting a bit confused, can you please elaborate on what you see exactly, and the steps you have taken, in detail?

I'm abouit to go wipe my hypervisor and update them with the latest image (rhevh-6.2-20120510.0.el6_2.iso) as I'm writing this.

 

At this time I am unable to see any new LUN's.. I've lost my log but I noticed when I did the scan the hypervisor(s) were complaining about a LUN being presented that was too big. I only have on presented currently which is lun 0 at 512GB

 

also, when I go to the hypervisor and issue fdisk -l it appears to me that it can see the 512GB disk just fine and even multipath sees the disk and does round robin.

 

I've gone back and even blown out the iscsi, recreating my raid 6 volumes and then creating some 512GB user volumes on top of that.. then presented those to the cluster with LUN 1, 10, 50, 100 (to test different ranges) but am unable to see anything.

 

These hosts were all part of the default cluster that I had to destroy originally to get rid of the storage domain that no longer existed... then I added them back to a new cluster manually.. which is why I'm wondering if I just need to wipe them completely.

 

 -- David

OK, since you're in the command line, can you clear the initiator cache

iscsiadm -m node -T IQN -o delete 

And try to run discovery again

 

Also, keep in mind that RHEV will ignore LUNs that are smaller than 10Gb or LUNs that have a RHEV tag on them, (or an FS) for fear of destroying someone else's data

Ugh.. ok thanks such a simple fix! I use dd if=/dev/zero of=/dev/<iscsi device> bs=1M count=1000 to wipe the first gig of the drive (over kill I'm sure)

 

I was able to do import domain and import my existing ISO domain back in.

I'm curious.. if I had a 'good' storage domain out there with VM's on it... is it possible to import that domain back to a system and for the system to see the VM's an import them? Something simular where VMWare will go oh look an existing VMFS, let's add it! Then you go browse that datastore and import your VM's.

No, RHEV will not touch an existing storage domain, because it might belong to another RHEV setup. To move VMs around you need an export domain. The additional difference between an export domain and a regular domain is that a regular domain is just an image repository, no VM metadata on it, so all the system will see is a bunch of images, with no VM definitions, which is not very useful. All the VM data is in the RHEV database