USB Mouse after install

Latest response

Hello,

 

I am installing RHEL V5.6 onto a "brandy spanking new" PC (an ASUS x54)

 

This install worked Swell onto an older (say 2 years?) DELL Inspiron

 

Bit now I have two issues with the New PC.

 

A:  During the install anaconda runs the XServer and sees my USB (Logitech) mouse and proceeds nicely. After the final reboot, it sumbles on trying to start the XServer complaining that maybe my mouse is not configured well enough (it does complain about not being able to query the Synaptic Hardware, which is likely the laptop's mouse-pad.)

 

I find it odd, since it had no trouble during the installation. And even stranger, the GUI screen it puts up asking if I want to review the XServer log, shows my mouse and allows me to move it around the screen !

 

Is there a config file or something somewhere that allows to to tell the XServer to skip the Synaptic stuff and just run the USB Mouse??

 

B:  And nextly can anyone offer some help about trying to get the OS the see my motherboard ethernet card? The ifconfig comes back with the loopback device AND another named wlan0 and even shows its MAC address. So I (assume) need a driver?  And if so, how does one go about finding out which one to use?  I tried going to the ASUS website hoping it would offer a linux driver but no joy :<

 

Thanks for any info you might provide!

tony

Responses

Tony,

 

You're probably better off running a newer version of RHEL 5 (say, RHEL 5.8) which may have more hardware enablement added to it. Are you able to update to this newer version?

 

Thanks!

 

Andrius.

Red Hat, Inc.

Thanks Andrius!

 

Well, I did just update my subscription to get V6 --- but I *was* trying to mimic that DELL's env.

 

BUT  maybe I'll give the V6 a try ..

 

C-YA in about 30 minutes ;<>)

 

Yes! Give RHEL 6.2 GA a try, or better yet, give RHEL 6.3 Beta a try, the new hotness! :-)

 

Regards,

 

Andrius.

Red Hat, Inc.

I know, it twas a bit longer --- but I GOTTA MOUSE!!!

 

But I still don't have any ethernet...

 

ifconfig does show the wlan0 and its MAC address...

 

Any ideas as to how to resolve the Lan Driver (or whatever it might be....) ??

 

Thanks!

Is the hardware in the HCL?

 

http://hardware.redhat.com

Andrius, thanks for hanging in there with me...

 

There are only a few ASUS peripherals listed and none of them appear to be ethernet interfaces (mostly video cards)

 

Are you aware of any INSTALLTION LOG or some such that would have generated any info that would be useful in this endeavor?  Do you know if there is any terminal command that woul dallow me to "see" hardware specifcs like the ethernet interfaces manufacturer, etc? 

 

Is there such a thing as a 'generic' eternet driver that I could try? And if so how do I load and apply it?

 

Thanks again,

tony

 

 

p.s. I had Ubuntu on this machine for about 1/2 an hour and it ran the ethernet interface just fine... in case that helps ;<>)

 

even more p.s. I found that there is an Atheros AR8131 gigabit controller onboard. I even found the AR81Family-Linux-v1.0.1.9.tar.gz for it...  But it expects to be "Made" and complains about LINUX source files not being found....I assume this means I need to hunt down some kind of Linux Kernal Devel files or some such?

I was able to install the Kernel-headers, and Kernel-devel but now MAKE complains that I have no compiler :<

 

Is there any EASY WAY to install these tools from the DVD in a single shot?  I started down the path of YUMming (via localinstall) the gcc from the DVD PACKAGEs folder *but* of course there are a bazllion dependencies all of which have another bazillion dependencies and so on...

 

thanks! 

 

Never Mind...  The "easy way" was just to use the ADD/REMOVE SOFTWARE gizmo and search for GCC !

 

 

So here's where I am:

 

1. make install theAR81Family --- no errors.

2. insmod atl1e   --- no errors

3. modprobe atl1e --- no errors

4. ifconfig

 

still shows LOOPBACK and the wlan0 but still not working

 

5. ifconfig wlan0 up   --- no errors

 

ifconfig shows no change.

 

I am sure I am really close now .... any ideas?

 

DOH! <face-palm-slap>  I just realized that the wlan0 interface is the WIRELESS interface. So even with all of the stuff above I am not even SEEING the wired interface!  

OK, I've done it --- I now have ethernet !!!

 

I found a reference to something called:  kmod-atl1e for RHEL V6 which you install AFTER the AR81Family package.

 

After that and a reboot --- voila'  ---- a working network interface.

 

Thanks for listening.

Brian - nice work! Great to hear the manufacturer created kernel modules for the driver - this should persist even with a kernel upgrade (which is a bonus).

 

Andrius.