Trouble activating host on RHEV3.0

Latest response

Here's the setup:

60day RHEV 3.0 evaluation.

RHEV Virtualization Manager running on a VM

RHEV Hypervisor running on a Dell laptop with virtualization enabled

 

Trouble: Adding the host to the Default cluster is not an issue. However, trying to "Activate" the host results in a "Host xxxx is non-responsive" error in the Events tab. Trouble is that I do not even know where to begin to check for issues.

 

Can someone here point me to where I can possibly start looking - logs etc - so I can get past this issue?

 

A bit of search took me to "vdsm" so I started looking... One thing I noticed in the vdsm log on the RHEV Hypervisor (if of any use) - /var/log/vdsm/vdsm.log - is :

 

MainThread::ERROR::2012-03-29 08:16:12,103::vdsm::74::vds::(run) Traceback (most recent call last):

File "/usr/share/vdsm//vdsm", line 72, in run

serve_clients(log)

File "/usr/share/vdsm//vdsm", line 40, in serve_clients cif = clientIF.clientIF(log)

File "/usr/share/vdsm/clientIF.py", line 92, in __init__

File "/usr/share/vdsm/libvirtconnection.py", line 94, in get

File "/usr/lib64/python2.6/site-packages/libvirt.py", line 102, in openAuth

libvirtError: authentication failed: authentication failed

 

and trying to start vdsmd results in:

 

/etc/init.d/vdsmd start

vdsm: Missing certificates, vdsm not registered [FAILED]

Starting iscsid:

Starting up vdsm daemon:

vdsm start [ OK ]

Responses

Hi Sanjay,

 

Welcome to Red Hat User Groups!

 

 

If I remember correctly, you were going to check your DNS setting to make sure name resolution works fine in your environment. How did that go?

Hello Dan! 

Yes, that is correct.

 

These machines are in a corporate environment. I'm waiting for IT to add DNS entries for these 2 machines. 

Meanwhile I wanted to check if someone might have run into something similar with their setup, maybe a few more pointers. 

 

Thanks!

IT added the necessary DNS records for both the hypervisor and the RHEV Manager machines. Both machines now talk to each other with FQDNs. However, my issue continues to exist... 

 

OK, lets try the following:

1. remove the host using the RHEV-M GUI

2. open the RHEV-H console

you should be able to see the configuration menu (over ssh, login as admin, not as root)

3. go to the RHEV-M part of the menu

4. Enter the RHEv-M's FQDN after "Managerment Server"

5. Enter 8443 as the management port

6. make sure "Connect to RHEV Manager and validate Certificate" is checked

7. Enter the admin@internal 's password twice

 

After this, the host should appear in RHEV-M GUI, with the status "awaiting approval". In the GUI, hit the "Approve" button, the host will get registered, reboot, and should come up after reboot as "Up".

Hi Dan,

 

I had already tried both ways

 

- add host from RHEV-M GUI

- add RHEV-M to the host via the method suggested by you

 

before reporting failure in my earlier post.. :(

 

hmm, ok, this means something went wrong. Can you try the procedure again, and provide the rhevm.log from the rhev-m machine as well as vdsm-reg.log from the host ?

I experienced the same issue when tried to add rhev6.2 to production environment. Unfortunately there was a time-critical issue to deploy a number of VMs and a decision has been made to extend alternative virtualization platform using these blades so I had no time to track this issue :(

I have a similar problem. In production I have 6.2, but the upgrade to 6.3, one of the hypervisors service not properly lifted vdsmd. :-(

 

I have opened a case with Red Hat.

A few things I had run into adding a RHEL host to RHEV, while using Fibre Channel

review the logs /var/log/vdsm/vdsm.log on the RHEL client, /var/log/ovirt-engine/engine.log on the RHEV manager host.

I had to disable friendly names for my Hitachi SAN storage and allow vdsm sudo (NOPASSWD) priviliges on the RHEL client.

Also - I ran into isssues if I had installed using a 6.3 image and updated the system prior to installing RHEV on that host. 

So, my procedure is:

  • to kickstart the RHEL host
  • bootstrap the host to my kickstart/Satellite with FULLY_UPDATE_THIS_BOX=0
  • updates sudoers and multipath.conf
  • ADD RHEL host to RHEV
  • update the RHEL host