Installing RHEV-M on a system using certificate-based RHN

Latest response

I was attempting to follow the RHEV-M installation instructions in the RHEV 3.0 Installation Guide, but I got stuck in section (Red Hat Network Configuration) with the "rhn-channel --add ..." commands.


These fail with a python traceback:


# rhn-channel --add --channel=rhel-x86_64-server-6-rhevm-3
Username: [username]

Traceback (most recent call last):
  File "/usr/sbin/rhn-channel", line 157, in <module>
  File "/usr/sbin/rhn-channel", line 121, in main
    result = subscribeChannels(, OPTIONS.user, OPTIONS.password)
  File "/usr/share/rhn/up2date_client/", line 128, in subscribeChannels
  File "/usr/share/rhn/up2date_client/", line 50, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/", line 206, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib64/python2.6/", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/", line 39, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.6/site-packages/rhn/", line 379, in _request
    request = self._req_body(self._strip_characters(params), methodname)
  File "/usr/lib/python2.6/site-packages/rhn/", line 234, in _req_body
    return xmlrpclib.dumps(params, methodname, encoding=self._encoding)
  File "/usr/lib64/python2.6/", line 1132, in dumps
    data = m.dumps(params)
  File "/usr/lib64/python2.6/", line 677, in dumps
    dump(v, write)
  File "/usr/lib64/python2.6/", line 699, in __dump
    f(self, value, write)
  File "/usr/lib64/python2.6/", line 703, in dump_nil
    raise TypeError, "cannot marshal None unless allow_none is enabled"
TypeError: cannot marshal None unless allow_none is enabled


I'm guessing this may have something to do with the fact that this system (running RHEL 6.2) was registered with the new certificate-based RHN, whereas the instructions seem to assume a system using the older "RHN Classic" method.  My understanding is that "channels" no longer exist under the new certificate-based RHN.  Can anyone confirm this?  Are there updated instructions somewhere that explain how to give a machine access to the RHEV-M software using the new certificate-based RHN?


Hi Paul,


Great post! I believe you are correct - the RHEV-specific guides don't go into a lot of detail with Red Hat Subscription Manger (via certificate-based RHN).


You might want to follow the instructions in RHEL 6 Deployment Guide instead, since RHEV-M sits on top of a standard RHEL install:


As for RHEV-H, that's a different story - I also believe the only way to register a RHEV-H box is via Subscription Asset Manager (SAM), which is now in Beta. If you use standard RHEL as a hypervisor, SAM should not be required, AFAIK.


I'll try to dig up some more folks to chime in though. :-)





Red Hat, Inc.



I have just registered a RHEL host that will be a RHEV host as well.   I used the certificate-based rhn method.


How do I add the RHEV channels?   


I get this error when I query rhn-channel.   The yum check-update shows that I do have a registration completed.





# rhn-channel --list
Unable to locate SystemId file. Is this system registered?

# yum check-update
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.
This system is not registered with RHN.
RHN Satellite or RHN Classic support will be disabled.
dell-omsa-indep                                          | 1.9 kB     00:00     
dell-omsa-specific                                       | 1.9 kB     00:00     
rhel-6-server-cf-tools-1-rpms                            | 2.6 kB     00:00     
rhel-6-server-cf-tools-1-rpms/primary_db                 |  17 kB     00:00     
rhel-6-server-rpms                                       | 3.7 kB     00:00     
rhel-6-server-rpms/primary_db                            |  12 MB     00:26     

kernel.x86_64                   2.6.32-220.17.1.el6           rhel-6-server-rpms
kernel-firmware.noarch          2.6.32-220.17.1.el6           rhel-6-server-rpms
perf.x86_64                     2.6.32-220.17.1.el6           rhel-6-server-rpms



RHEV-M does not yet support certificate-based RHN, so this is expected behavior.


If you are running RHEL as a hypervisor (and not RHEV-H), then RHEV entitlements should not be required and is still only RHEL.


Are you are talking about the actual RHEL system that has RHEV-M running on it?







thanks.   I am running RHEV on a RHEL 6.2 host.   The RHEV-M host is another mini-server.


If I read your comment correctly, I should use channel-based Classic RHN, and not certificate based?



use the command

yum-config-manager --enable <<channel required>>