RHEL 6.2/Dell R710 UEFI install reboots to GRUB prompt

Latest response

I recently installed RHEL 6.2 onto a brand-new Dell R710 with UEFI enabled.  It sees the 4TB drive array fine, and installs fine...but when it attempts to reboot after the install, it returns to a GRUB prompt every time.  I have tried booting to the grub.EFI file, which is installed in the expected place, but it returns me to GRUB each time.  Is there a problem with RHEL 6.2 and UEFI, or is there something I need to do specifically?  I have searched RHN from one end to another without result.

Responses

Hi Bill. Sorry you are having trouble with RHEL 6.2 on your UEFI box. The problem is described in this bug report:

 

https://bugzilla.redhat.com/show_bug.cgi?id=719711

 

We also ran into it when we went to RHEL 6.2 for the Red Hat Enterprise Virtualization Hypervisor. This bug report describes a workaround, which includes booting to the BIOS and turning on Legacy Mode:

 

https://bugzilla.redhat.com/show_bug.cgi?id=747102

 

I believe the problem is being worked on since running in Legacy Mode is not a preferred long-term solution.

Did the same here, that is, booted to legacy BIOS.  Our problem has always been having to carve out an additional RAID partition just to boot from.  UEFI was supposed to fix that, and we've been waiting on a UEFI-bootable Redhat since the first RHEL 5 beta.

I also experienced this problem, but on an older Dell PowerEdge 2950 machine.  My workaround was to install using the 6.1 iso and then upgrade to 6.2.

Do we have steps to take a fresh load 6.2 on EFI from unusable to bootable.

 

Del 710

RAID 5 x 4 x 2Tr drives

Help me if you can.

 thanks for help