Mouse / Keyboard problems when installing RHEL on RHEV 3

Latest response



When installing a RHEL 6.2 guest on a virtual server (hosted on RHEV 3 Hypervisor) using the SPICE client, the mouse and keyboard will randomly stop working. I have tried restarting the guest, and managed to get further, even as far as the reboot and then as far as configuring kdump, but again after a few minutes the mouse freezes again and the keybaord is again unresponsive.


I have installed Windows 7 and XP guests on the same hosts and did not have this problem. With the RHEL guest I am using VirtIO.


Does anyone have any suggestions about this? 


Hi Piotr. 


No, virtio has nothing to do with this. Do you have the QXL xorg driver and the RHEV tools installed in the guest?

Are you accessing the guest's console directly, or through another remote viewer app?

Hi Dan,


No I don't have QXL xorg drivers installed, since you asked I tried reinstalling RHEL6.2 to see if this was an option available in the normal installation process, but as soon as the installation GUI appeared; the mouse was frozen, the keybaord unresponsive. 


Yes I am accessing the guest directly through SPICE alone, no other viewer involved. 

thanks. I'm actually setting a RHEL6 VM right now as well, once I'm done I'll post the right steps

Hi Dan,


I'm assuming that you did not run into the same issue?

Adding the right channel:

rhn-channel -a -c rhel-x86_64-rhev-agent-6-server

(there are relevant channels for other bittage and RHEL5 guests, just run rhn-channel -L to see the full list)


yum install rhev agent

service rhev-agentd start

chkconfig rhev-agentd on


make sure xorg-x11-drv-qxl is installed


After that my VM was working perfectly, and I'm accessing it over a poor congested WAN

Thanks Dany, but to clarify, this must be installed on the guest via command line? It sounds like the problem might be me choosing the desktop RHEL installation rather than the headless server RHEL installation...


Did you do this via the command line or using the GUI?

The yum and rhn-channel commands I ran in the cli console. xorg-x11-drv packages are of course for the GUI

This is not the problem I'm having. Installing onto a virtual machine via rhevm does not succeed, the rhel 6.2 .iso is loaded, the virtual machine booted using the 'Attach CD' option within rhevm. The installation begins, and at some random point before the installation is complete, all keyboard and mouse becomes frozen. No further progress is then possible.


I am not able to install even a headless system and attempt to use the server via ssh alone; I repeat, the installation process cannot be completed. I have successfully installed a Windows 7 virtual guest, and a bodhi-linux virtual guest so far. So this issue seems particular to RHEL on RHEV.


OK, now I see what's going on. This is quite unusual, but I have two suggestions to try nonetheless:

1. Try with another ISO image (and test this one with md5sum)

2. try to run the setup in Run-Once mode with VNC instead of Spice - does it make a difference?

Hi, good suggestion, under VNC the problem doesn't occur. 

I see, so there is some sort of conflict with Spice or QXL. Can you install the VM using VNC and then start it again with Spice instead? I wonder how it will behave then.


If the VM fails to boot with Spice, you can switch back to VNC, start the VM up, and see the logs in the VM - that should provide us with a lead


It's very odd, I can't see a clear pattern between SPICE working and not working. The issue seems to only occur with Linux, RHEL and Fedora 16, I also had problems with Ubuntu 10.04 and contemporary Linux Mint. Bodhi installs and runs ok.


With a Fedora install using VNC, the guest functions for now using SPICE. But another Fedora guest, from the same .iso, does not function properly, the screen goes black at boot when it should be loading the login screen. With another guest using RHEL I am able to boot the guest, log in, move the mouse... but then the keyboard doesn't work.


So, all over the place really. As VNC does work I'll just use that and hope that patches and updates over the next few months will work out whatever artifacts I'm experiencing here. 

I have tried to reproduce this on several differently configured setups with different hardware - with no luck. Can you post some details about your setup - what hardware is used, how it is configured, logical networks, display networks and vlans, VM details... Anything that is relevant really


BTW, do even VMs with no X server installed fail to boot with spice?