rhevh install fails with Dell raid controller

Latest response

I tried several permutations of RAID settings on my server,

and in every case the installation would complete, but the

server would not be able to boot.

 

I expected to see a disk option for my RAID 1 logical drive,

but it did not show up in the list.  Rather there were /dev/mapper

paths to each of the individual drives.  I tried using RAID 1

with two drives, RAID 0 with one drive, and then deleting all

logical drives on the RAID controller.  No joy.

 

Here is the output of lspci -v for the controller.

 

00:1f.2 RAID bus controller: Intel Corporation 631xESB/632xESB SATA RAID Controller (rev 09)
    Subsystem: QUANTA Computer Inc Device 8950
    Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 20
    I/O ports at ec00 [size=8]
    I/O ports at e800 [size=4]
    I/O ports at e400 [size=8]
    I/O ports at e000 [size=4]
    I/O ports at dc00 [size=32]
    Memory at fdffbc00 (32-bit, non-prefetchable) [size=1K]
    Capabilities: [70] Power Management version 2
    Capabilities: [a8] SATA HBA <?>
    Kernel driver in use: ahci
    Kernel modules: ahci

 

Responses

Hi Carl,

 

Which Dell RAID controller are we talking about? Is it a SAS5/6/H200 or a PERC5/6/H700?

 

The reason I ask is, the first set of controllers are actually fakeRAID, while the latter are real RADI controllers.

 

Linux in general, does not directly support fakeRAID, only through mdraid or 3rd party drivers, while for real raid controllers there are kernel drivers.

 

See http://en.wikipedia.org/wiki/RAID#Firmware.2Fdriver-based_RAID for details

 

 

Hope this helps

Dan

It sounds like this is fakeraid as Dan mentioned. This is not supported by RHEV-H at all. This will be documented in RHEV 3 RHEL 6 based RHEV-H hypervisors as such in the Deployment guide:

Fakeraid Devices are not Supported

The Red Hat Enterprise Virtualization Hypervisor does not support installation
on fakeraid devices. Where a fakeraid device is present it must be reconfigured
such that it no longer runs in RAID mode.

  1. Access the RAID controller's BIOS and remove all logical drives
    from it.
  2. Change controller mode to be non-RAID. This may be referred to as
    compatibility or JBOD mode.

Access the manufacturer provided documentation for further information related
to the specific device in use.