Software issues in MS based VMs

Latest response

I'm not sure this is the proper category for this. I am evaluating the beta for RHEV 3. We have a few Virtual machines installed (Win XP, 2008 R2 (both standard and datacenter)) and have been having issues installing our antivirus product we use for MS computers. (Sophos) I know the package is good because it has been used on physical machines. The install essentially hangs when I run the executable in one of our VMs. What would I need to provide for diagnostic information? I have not really found anything helpful in the log files for the software or the Windows event viewer.

 

Responses

Hi Thomas. As you probably know, troubleshooting 3rd party software can prove extremely tricky. I am not aware of specific conflicts with Sophos, but usually such behaviour is not limited to VMs, but also conflicts with other software and drivers.

 

Though it is possible in Windows 2008 to dump a memory stack of a process for debugging, without the proprietary symbols for debugging, this data is almost worthless. 

 

I would suggest you open a support case with Sophos and we will provide information they might require from the virtual platform side.

 

What you can try in the meantime, just to give us a direction is:

- set up a clean windows VM with an IDE based disk and e1000 networking device

- do not install any RHEV guest tools

- try to install the antivirus and let us know if it worked. 

 

If the insall works, we might try to start adding RHEV components one by one, and reinstalling the antivirus, until it hangs again, in order to pinpoint the component that conflicts (virtio disk, virtio network, guest agents etc).

A few ideas:

 

  • Set the VM in the Excluded Items section of Sophos
  • Disabling the on-access scanner altogether when booting the VM

This issue doesn't sound specific to RHEV - I recall people having this same issue on other Virtualization platforms such as VMWare...

Well I can't even install the Sohpos software on the virtual machine. I tried resetting up a clean Windows 7 install with an IDE based disk and an rtl8139 network card and the same thing occurred. Did not load any guest utilities. We have a support case open with Sophos and they are supposedly going to setup an RHEVM environment to figure out the issue. Is there anything I need to pass on to them?

 

Tom

Tom - I can't think of anything to pass on to them other than to focus on similar QA testplans with other virt platforms and apply those to RHEV if possible. Sophos can download and try RHEV via the trial website:

 

http://www.redhat.com/promo/rhev3/

 

Thanks, and keep us posted, we are interested in finding out what happened.

 

Andrius.

Red Hat, Inc.