older libraries

Latest response

Application requires glibc 2.4. Can this be installed on RHEL 5.3? Current version is 2.5. Package manager does list 2.4.



There is no supported version of glibc-2.3 available for any update level of RHEL 5.


That said, glibc 2.5 is backwards compatible with 2.3, and thus your application should have no problem running on 2.5.  Have you attempted to run it?  Is there a specific reason why you have to use 2.3?



John Ruemker, RHCA

Red Hat Technical Account Manager

Online User Groups Moderator

If, for some odd reason, the application was linked against a specific and older version of glibc (verify with ldd), you could potentially create a symlink for the older libc version to the RHEL-current one on the host.

Most apps I've looked at are generally just linked against libc.so.6.

[pjensen@m0000001 zones]$ ldd /bin/bash
libtermcap.so.2 => /lib64/libtermcap.so.2 (0x000000368fa00000)
libdl.so.2 => /lib64/libdl.so.2 (0x000000368e600000)
libc.so.6 => /lib64/libc.so.6 (0x000000368e200000)
/lib64/ld-linux-x86-64.so.2 (0x000000368de00000)