Scheduled package update from RHN is stuck in queue

Latest response

I just registered my system using rhn_register. After I was able to do that successfully, I created a package of all the updates in the RHN customer portal, and scheduled it for installation. That was last night, but it's still listed as "in progress". The earliest it is scheduled for install is "5/5/11 7:25:29 PM PDT", which was last night.

 

Obviously I'm missing something, but I can't figure out what.  How can I get this update triggered and pushed to my system?

Responses

I ran rhn_check from the terminal window, and that seems to have applied the update package that was stuck in queue. I suppose I can schedule a cron job for this or something too.

 

Was that the "best practices" way to apply these updates, or is there a better way to go about this?

Hi John,

There is a daemon called 'rhnsd' which will periodically check in with RHN and see if there are any pending actions, and if so, execute them.  Without this, actions will not get automatically picked up by clients, and as you discovered, a manual run of rhn_check is required to check for them. 

 

The rhnsd package is not installed/enabled by default, so you would need to install it to achieve this functionality.  The package is in the standard RHEL base channels, so if your system is registered then all you need to do is:

 

  # yum install rhnsd

  [...]

  # chkconfig rhnsd on

  # service rhnsd start

 

By default, the polling interval is 240 minutes.  You can configure this (with a minimum allowed value of 60 minutes) in /etc/sysconfig/rhn/rhnsd.  Once you've started the rhnsd service, you may want to schedule another action just to test if it gets picked up automatically.

 

Let us know if you have any questions.

Regards,
John Ruemker, RHCA

Red Hat Technical Account Manager

Online User Groups Moderator