Need help for setting up yum

Latest response

Hi all:

 

I have issue with yum update, when I type "yum install http" I got follow info:

 

# yum install http
Loaded plugins: refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
No package http available.
Error: Nothing to do

 

 

so how to registered my Redhat?
 

Responses

Hi Danny,

 

You can find the information in detail in the following article:

 

https://access.redhat.com/discussion/system-registration-getting-your-system-and-running

 

Cheers,

Daniel

Hi Danny,

 

 

To register you need to run:

 

rhn_register

 

for this to work you need a red hat login for Red Hat network

check if you can login to http://rhn.redhat.com with the userid that you use for this discussion forum.

 

second point: apache webserver is provided by httpd*.rpm

 

so:

 

yum install httpd

 

 

Kind regards,

 

 

Jan Gerrit Kootstra

Hi all:

 

it pop up a message siad "We could not contact Red Hat Network .........."

and I did configure proxy and the server able to ping to internet (which I try the google.com).

 

so did I missing anything?

 

Danny

There is no package named http, it should be,

 

# yum install httpd

 

Best Regards,

Jaylin

Yum does globbing, so `yum install http*` would work, as well. Just be careful that when you glob with yum that you don't create an overly-broad yum action.

Hi! As a reminder, the Red Hat Knowledgebase contains a wealth of information and answers to frequently asked questions, including tips on registering or re-registering to RHN.

 

https://access.redhat.com/kb/knowledgebase/

 

Here is a sample search

 

Hope this helps!

it pop up a message siad "We could not contact Red Hat Network .........."

and I did configure proxy and the server able to ping to internet (which I try the google.com).

 

so did I missing anything?

 

Danny

Hello Danny,

 

Please edit the /etc/sysconfig/rhn/up2date file from the system and enter the proxy server details and then try to register the system.

 

For more information please see:
https://access.redhat.com/kb/docs/DOC-9826

 

regards,

 

Vishal.

Hi all:

I configure up2date as follow: 

enableProxy=1
httpProxy=http://xxxx.xxxxx.com/proxy.pac

but still same message came up. this proxy i use in same server go to web ware fine.
anything I miss? please help!


Thanks
Danny

Hi Danny,

see the comment for httpProxy at up2date file:

httpProxy[comment]=HTTP proxy in host:port format, e.g. squid.redhat.com:3128

yum does not understand the configuration over a proxy.pac file.

Regards,

Uwe