Share your feedback on the RHEL 7 Beta!

Latest response

Thanks for the great response so far! It's been exciting to get your feedback on the RHEL 7 beta. Keep it coming, but as this thread is starting to get long, please start a new discussion for each new issue instead of adding it here. This will help us keep track of separate issues and respond to you as quickly as possible. - Admin

As you know, Red Hat has recently released the Red Hat Enterprise Linux 7 Beta. You can find out more about this new release at:

RHEL 7 Beta Product page
- This is the main landing page for Red Hat Enterprise Linux 7 Beta. From here you can download the Beta, request Beta subscriptions (to enable registering and subscribing via Red Hat Subscription Management), and requesting 30-day evaluation subscriptions.

All things RHEL 7 Beta, and an FAQ around its release
- You're in a hurry, but need to get the summary around the Beta. Start here to get the most frequently asked questions to date on the Beta!

What's New in Red Hat Enterprise Linux 7 Beta?
- Get more details about the product itself, and what's been added compared to RHEL 6. Check out all the benefits of this release!

Get Started with Red Hat Enterprise Linux 7 Installation
- Check out this "quick start" guide if you aren't interested in the full-blown Red Hat Enterprise Linux 7 Beta Installation Guide written by the documentation team.

More importantly, we want your feedback on how the Beta is working for you so please share your comments, feedback and ideas below, and while you're at it take a chance to earn $500 for filling out our brief survey.

Thanks again for your interest in Red Hat Enterprise Linux 7 Beta!

Responses

Have userA install RHEL7 and get it subscribed with subscription-manager

Have userB log into portal and delete userA's subscription management unit.

Watch the fun ensue :)

Hi Daryl, can you be more specific on the use case? Are you saying two different people are using the same RHN login, or are you saying an Org Admin is managing subscriptions without the sysadmin knowing?

From speaking with our systems management team this sounds like a known issue and is actively being worked.

Thanks for the comment!

Howdy, We have a long standing ticket with GSS open on this issue and were told it would be resolved in time for the RHEL7 beta. Unfortunately, it appears to remain. Users within an org are able to delete/view each others consumers from RHN. RedHat calls this a feature and not a security bug, which we think it is :)

daryl

I have not tried this release yet. Has anyone noticed changes to the installation process in RHEL 7 Beta? I am hoping for some minor improvements to speed up installation.
For example, in RHEL 6, one must wait until the storage device is formatted before selecting packages to allow installation to finally occur. This is inefficient use of a sysadmin's time.
A lesser concern, but still an annoyance, is the poor ability of RHEL 6 to make use of wireless networking during installation. Even Debian is not perfect in this regard but in my experience RHEL is worse.
These are merely suggestions for improving a product that is already excellent!

Appreciate the suggestions, Jonathan - and thanks for the positive feedback. Let us know when you've tried out the beta, too!

Hi Jonathan, the installer has been updated in RHEL 7 and will address both of these issues. It does not require waiting for device formatting to complete before you can access software selection. It follows a different model, so you can choose which parts you want to configure in your own preferred order or even skip certain configuration. You can also make use of wireless networking during installation; the support provided is very similar to NetworkManager's support. Please let us know your thoughts once you've tried it out!

Hi all,

What annoyed me a little is the Dutch translation of the installer. Some crusial parts, e.g. kdump setup are still not translated.
I hope this will be fixed before GA release.

What I found a bid strange too is the Gnome screen size on my KVM guest is very big. So I have to scroll all the time to see the complete desktop.

Kind regards,

Jan Gerrit Kootstra

Sorry about that Jan Gerrit, and thanks for the feedback on these issues.

David,

It is a beta, not a general available release. So a few issues might be found.

Kind regards,

Jan Gerrit

Hi Jan,

Thank you for testing the Beta with us.

The localisation problem you mention is being tracked internally already. I'm working to get more information on the status of the translation for you.

For the KVM screen size problem, can you try setting "Scale Display" to always on please? You can find that in the View menu of the virt-manager client screen. you may need to tweak the window to make it take effect, but I've been using this with success here.

met vriendelijke groet
Mark

Hello again Jan,

The Engineer has confirmed that the process is to pull the latest anaconda translations with each build. We do those upstream at https://fedora.transifex.com/projects/p/anaconda/language/nl/ so going forwards, the translation will improve.

met vriendelijke groet
Mark

nice

Extra hint: I am talking about Dutch translation, not Flemish. For I do not know the Flemish language enough to judge the translation.

Thanks for the hint.

The scale display hint is very useful.

Is it supported on RHEV 3.2 ? I have tried it and failed with error right after the first screen that let me choose if I want to install or trouble shoot.
[ 3.014565] ioremap error for 0xffff...

Hi Stefan,

I'm not seeing that error when I try installing on RHEV 3.2

Are you able to get a screenshot from the spice console and open a ticket for the issue please? If not, just a screenshot I can grab would be helpful.

Many thanks,
Mark

I have started it in limited gui mode (or something similar named) and it worked.

I had the same problem. Booting in "basic graphics" mode allowed it to work..

Maybe an issue with plymouth compatibility?

I had this one too. But only if the VM was just created and on the first boot. The next boot did worked for me.

When I double-click on the DVD-icon on the desktop, all icons dissapear for a second. If I do this a second time, the desktop crashes and I need to relogon. See also http://remoteoutpost.nl/rhel7.jpg

Might be worth noting that I installed RHEL7 in VMWare Workstation, so the drive is virtual. The onyl way to open the DVD within RHEL7 is to remount it, and when the pop-up appears, click open files, and it will open the dvd-contents. (double clicking the dvd-icon on the desktop still makes gnome crash).

This sounds like an odd issue, Rob. Thanks for the feedback - we'll investigate.

Is this available for testing from Satellite servers at all?

I might be burned at the stake for this - but I'd have been tempted to delay RHEL 7 to allow more systemd goodness to arrive.

Cheers

D

Hi Duncan!

I'd say, please jump right in, even if you've seen systemd in action on Fedora!

If you know systemd already, you will be in a great place to make sure it does what you need and feedback means we can request that engineering investigate any corner cases you find.

I've opened up a new thread for RHEL 7 Beta systemd Discussion, so please comment in that thread if you find anything!

Many thanks,
Mark

Yep I've synched down the channel already. Kickstart tree doesn't appear to be seen by cobbler for some reason but the channel is there for hosts built by hand to update and install packages from.

Get a new satellite certificate, ensure everything-7-beta is in the list and do:

satellite-sync -c rhel-x86_64-everything-7-beta

Then you should be good to go!

That channel doesn't show up for me.

I'm sure you've already re-generated a new certificate XML file right? Just wanted to confirm.

Um, sure I have.

(quickly activates Satellite with new cert)

Oh - there it is. Maybe I didn't see it before? :-/

I did the same thing. I think it's kind of weak that satellite certificates are set up this way. It was more confusing the first time I came across it with Software Collections.

I still don't have kickstarting against Satellite 5.6 sorted. I'm at a loss for getting it running and will be building from media for now.

I am a bit amazed that Puppet isnt included, especially with the way Satellite 6 is going.

Likely method for getting this out will be a sub channel similar to RHN Tools which includes the necessaries for Satellite 6 clients.

I like using the Puppetlabs repos as a yum-repo-backed Satellite child channel anyhow.

Puppet is in EPEL 7 now but it's such a new version we won't be able to use it for now. And I'm told that Puppet and Ruby 2x don't get along so I probably wouldn't count on the version in EPEL to work well out of the box w/ RHEL 7 anyhow.

KVM text based install. Networking not set up correctly either by dhcp or manual method. Had to hand edit config files after install was complete to get networking fully functional.

I wish I would have thought to save the auto generated files for an example but I just wiped them and added the info in manually. Seemed like it was either a gateway issue, netmask or routing (again sorry) on the manual config. Never made it through an install w/ dhcp setting, wouldn't detect it and installer would not let me pass without networking configured??

Hi Lincoln,

I've opened up a new discussion thread for networking issues, and I'd like to include this one (which I haven't been able to reproduce yet).

Networking with RHEL 7 VM Installation using KVM

Please can we follow up there?

Many thanks
Mark

I have tested our own product which is still 32-bit and got a problem with the message queue
system calls:

The following test program is OK if compiled as 64 bit application,
but gave the error
msgrcv: No message of desired type
if compiled as 32 bit application:

include <stdio.h>

include <string.h>

include <unistd.h>

include <sys/types.h>

include <sys/ipc.h>

include <sys/msg.h>

struct msgbuf
{
long mtype; /* message type, must be > 0 /
char mtext[16]; /
message data */
};

static int msr(int msqid)
{
struct msgbuf msbs;
struct msgbuf msbr;
ssize_t sret;
long mtype = 121;

memset(&msbs, 0, sizeof(msbs));
msbs.mtype = mtype;

if (msgsnd(msqid, &msbs, sizeof(msbs.mtext), IPC_NOWAIT))
{
perror("msgsnd");
return -1;
}

sleep(5);

sret = msgrcv(msqid, &msbr, sizeof(msbr.mtext), -mtype, IPC_NOWAIT | MSG_NOERROR);

if (sret < 0)
{
perror("msgrcv");
return -1;
}

if (msbr.mtype != mtype)
{
printf("found mtype %ld, expected %ld\n", msbr.mtype, mtype);
return -1;
}

if ((size_t)sret != sizeof(msbs.mtext))
{
printf("received %lu, expected %lu\n",
(unsigned long)sret, (unsigned long)sizeof(msbs.mtext));
return -1;
}

return 0;
}

int main(void)
{
int ret;
int msqid = msgget(IPC_PRIVATE, IPC_CREAT | IPC_EXCL | 0666);

if (msqid < 0)
{
perror("msgget");
return -1;
}

ret = msr(msqid);

if (msgctl(msqid, IPC_RMID, 0))
{
perror("msgctl");
return -1;
}

return ret;
}

Hi Gabriella,

thank you for helping us test RHEL 7.

I think the problem in this case, is in the following line:

sret = msgrcv(msqid, &msbr, sizeof(msbr.mtext), -mtype, IPC_NOWAIT | MSG_NOERROR);

we changed that to

sret = msgrcv(msqid, &msbr, sizeof(msbr.mtext), mtype, IPC_NOWAIT | MSG_NOERROR);

and got the same results with both 64 and 32 bit binaries

Best regards,
Mark

Yes, but this is not the same!

from the man page:

The argument msgtyp specifies the type of message requested as follows:

  1. If msgtyp is 0, then the first message in the queue is read.

  2. If msgtyp is greater than 0, then the first message in the queue of type msgtyp is read, unless MSG_EXCEPT was specified in msgflg, in which case the first message in the queue of type not equal to msgtyp will be read.

  3. **If msgtyp is less than 0, then the first message in the queue with the lowest type less than or equal to the absolute value of msgtyp will be read. **

Hi Gabriella,

yes I see your point. I'm going to follow up with some people internally and will get back to you, there are clear differences in the strace output, so we will investigate.

Many thanks,
Mark

Thanks for posting feedback. A tip for posting "code" - you can use 3 x tilda's to start and stop the code section
"~~~"

Everyone! Thank you so much for your comments and feedback here!

We've noticed that there are a wide variety of topics being posted and we want to make sure that each one gets the proper attention. So, we'd like to encourage everyone to either join a post with a topic that is relevant, you can search the list here or you can create your own.

Thank you again for participating,
Mark

I'd love to know if this is happening to others:
https://access.redhat.com/site/discussions/644253
RHEL 7 Beta: Creating a Satellite kickstart - "No trees were found"

I've already had users unhappily note that Mate is not included in the everything channel. I'm sure many people will be asking about this.

Hi Kodiak,

Thank you for helping test the Beta.

I'll make sure that this is noted and the Product Management Team are informed.

Best regards,
Mark

[Moved]

[Moved]

Pages