resolve dependency

Latest response

During the process of updating the system, we were faced with the impossibility of resolving the dependency. We receive the following message:
Error: Package: python2-qpid-proton-0.34.0-1.el7.x86_64 (@ priorbank_jsc_Fedora_Fedora_EPEL__RHEL7 __-_ main)
Requires: qpid-proton-c (x86-64) = 0.34.0-1.el7
Removing: qpid-proton-c-0.34.0-1.el7.x86_64 (@ priorbank_jsc_Fedora_Fedora_EPEL__RHEL7 __-_ main)
qpid-proton-c (x86-64) = 0.34.0-1.el7
Updated By: qpid-proton-c-0.35.0-1.el7.x86_64 (priorbank_jsc_Fedora_Fedora_EPEL__RHEL7 __-_ main)
qpid-proton-c (x86-64) = 0.35.0-1.el7
Available: qpid-proton-c-0.28.0-3.el7.x86_64 (rhel-7-server-satellite-tools-6.8-rpms)
qpid-proton-c (x86-64) = 0.28.0-3.el7
Available: qpid-proton-c-0.28.0-4.el7.x86_64 (rhel-7-server-satellite-tools-6.8-rpms)
qpid-proton-c (x86-64) = 0.28.0-4.el7
The solution described here did not help, since this package is used not by gofer and katello-agent, but by other packages. The system used is RHEL7 and the repository used is by Satellite server.
Is it possible to solve this problem and maybe you can explain why there is no python2-qpid-proton package in this repository(, although yum info says that it was downloaded from there. I attach screenshots.


Hello, python2-qpid-proton has been replaced by python36-qpid-proton in the EPEL repository. Could you try replacing those two packages on the system, if that resolves the dependency problem?

I solved this by doing: yum erase qpid-proton-c ; yum update -y ; yum install qpid-proton-c -y If the erase got rid of katello-agent and python-gofer-proton and python-qpid-proton and you need those you can install those again after.

I used VA's option to yum erase qpid-proton-c which also removed python2-qpid-proton and python-gofer-proton. After yum update finished qpid-proton-c and python-gofer-proton seemed to have been reinstalled during the update. When I tried to yum install python2-qpid-proton, it failed to install with "No package python2-qpid-proton available." I am going to wait to see if the application group has any issues with this package missing. If they need it I will add the EPEL7 repository back into the servers repositories.