JBoss eap6 runtime Empty in eclipse

Latest response

Hi,

I have migrated to JBoss EAP 6 in Eclipse Juno. I am not using maven. I have intalled befor the JBoss tools JUNO (version 4.0).
I have specified JBoss EAP 6 runtime in my Java Build Path, but it was EMPTY !!.
So my question is why is it empty and how to fix this ?

Responses

I'm not sure what you mean when you say you have migrated EAP 6 in Eclipse Juno. Are you trying to run EAP from the within the IDE?

You can download JBDS which comes bundled with EAP (if you wish) from here [1]. There are full instructions on how to run EAP from within the IDE in the documentation [2]

[1] https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?downloadType=distributions&product=jbossdeveloperstudio&version=7.0.0

[2] https://access.redhat.com/site/documentation/Red_Hat_JBoss_Developer_Studio/

I am using Eclipse Juno IDE and don't want to use JBoss Developer Studio as the team is working with Juno.
So how to fix this problem in Eclipse.

We don't support Eclipse and JBDS IS Eclipse with JBoss Tools installed. JBDS 7.x is running Keplar which is newer than Juno release.

Ok but by installing JBoss Tools Juno in eclipse, it should work as well as in previous JBoss runtime settings.

Is this EAP 6.1 or 6.0? This is more than likely because EAP 6.x Runtime is not supported on JBoss Tools 4.0. I'd have to check but JBT 4.0 was included in JBDS 6.x which has EAP 6.0 runtime support but EAP 6.1 was tech preview. You can download JBT 4.1 from [1] but you need Keplar unfortunately.

However, the problem you have is still unclear to me. If you specified EAP 6 in the build path then what exactly is empty? Do you mean you tried to add it as a library but you couldn't select it?

[1] http://www.jboss.org/tools/download/installation/update_4_1

Yes unfortunately i am using JBoss tools Juno (version 4.0), and My server is JBoss eap 6.1. So it's more clear to me. Thanks.