RHEL 8.2 Fails to Boot

Latest response

I have a task to upgrade from RHEL 7.2 to RHEL 8.2 without going through the approved Red Hat migration path. Our program is running in a VMware environment using UEFI on HP servers.

Our method is to "clone" the rootlv, usrlv, optlv, and varlv LVs from a base RHEL 8.2 image and share /boot and /boot/efi. This has been used successfully when upgrading from different RHEL 7 releases.

There is now a problem when booting the RHEL 8.2 image and the UEFI partition does not get mounted nor can it be mounted because the driver is not installed. I've tried the comment out /boot/efi entry in /etc/fstab and manually install vfat but have had no success.

The GRUB menu looks good and so does the default RHEL 8.2 menu entry.

Has anyone encountered this problem before? And if so, how did you work around the issue?

Combined RHEL 7/RHEL 8 GRUB

GRUB Default Entry

UEFI Error

Responses

Hi John,

What you did and try to do is not only NOT supported, but also NOT recommended ... unfortunately I have to say that so
drastically. Red Hat provides the possibility to upgrade from RHEL 7.9 to RHEL 8.4, so that would be a supported option.
Best option when it comes to upgrading from one major release to the next, would be a clean installation nevertheless. :)

Regards,
Christian

Thanks for your response but I don't have many choices at the moment. Just want to know what would cause the UEFI vfat partition cannot be mounted.

John, I completely agree with Christian.

If you suspect that the required modules are not present in the initramfs image file of the upgraded kernel then try rebuilding the initramfs image file for the new kernel. Have you tried this? If not then I suggest that you could boot into earlier working kernel and re-build the initramfs image file for the new kernel:

- Backup the required kernel initramfs image file and recreate it:
# cp /boot/initramfs-NEW-KERNEL-VERSION.img /boot/initramfs-NEW-KERNEL-VERSION.bak.$(date +%m-%d-%H%M%S).img

# dracut -f /boot/initramfs-NEW-KERNEL-VERSION.img NEW-KERNEL-VERSION

I checked the initramfs and the fat/vfat modules are present:

TFDM==>lsinitrd /boot/initramfs-4.18.0-240.10.1.el8_3.x86_64.img | grep fat drwxr-xr-x 2 root root 0 Feb 28 2020 usr/lib/modules/4.18.0-240.10.1.el8_3.x86_64/kernel/fs/fat -rw-r--r-- 1 root root 34904 Feb 28 2020 usr/lib/modules/4.18.0-240.10.1.el8_3.x86_64/kernel/fs/fat/fat.ko.xz -rw-r--r-- 1 root root 8572 Feb 28 2020 usr/lib/modules/4.18.0-240.10.1.el8_3.x86_64/kernel/fs/fat/vfat.ko.xz -rwxr-xr-x 1 root root 62448 Feb 28 2020 usr/sbin/fsck.fat lrwxrwxrwx 1 root root 8 Feb 28 2020 usr/sbin/fsck.vfat -> fsck.fat

There may be dependent module for vfat that could be missing. I'm not really sure though, however, there is nothing wrong in triggering a re-build of the required initramfs image in this situation. Also, take a look at the points that our community members have posted here.

All the best!

Just FYI for anyone landing at this discussion...

This article here https://access.redhat.com/articles/4263361 says to use the most current edition of Red Hat Linux which is version 8.4 as I type this on July 20th, 2021. Using a non-current edition of Red Hat Linux 8 is not supported (see the link in this paragraph for specifics).

    IMPORTANT:
    A path for an automated in-place upgrade is going to be provided only for the latest even number RHEL 8 minor version, for example RHEL 8.4.

The procedure of upgrading from RHEL 7 to RHEL 8 using the Leapp utility is documented in Upgrading from RHEL 7 to RHEL 8. Major differences between RHEL 7 and RHEL 8 are documented in Considerations in adopting RHEL 8.

Kind Regards,
RJ

Hi John,

What you are trying here is considered "experimenting way beyond production support" - I don't think that the official Red Hat
community is a good place for this, perhaps you may find something that helps you on portals like StackExchange for example.
RJ and Sadashiva : Thanks for confirming what I told John in my first response above. We really should follow Red Hat's advice.

Regards,
Christian

Thank you Christian for being a consistent sane voice here!

Regards,
RJ

You're welcome, RJ ! The same is valid for yourself. Thanks back to you. :)

Regards,
Christian