Error while upgrading RHEL 7.9 to RHEL 8

Latest response

Hi,
I have a server RHEL 7.9 with subscription to RHEL via Satellite that I am trying to upgrade to RHEL 8 using leapp upgrade.
I am getting this error while proceeding with leapp upgrade:
* ============================================================

ERRORS

2021-07-12 11:20:23.112807 [ERROR] Actor: target_userspace_creator
Message: Cannot find required basic RHEL 8 repositories.
Summary:
Hint: It is required to have RHEL repositories on the system provided by the subscription-manager unless the --no-rhsm options is specified. Possibly you are missing a valid SKU for the target system or network connection failed. Check whether your system is attached to a valid SKU providing RHEL 8 repositories. In case the Satellite is used, read the upgrade documentation to setup the satellite and the system properly.

============================================================

END OF ERRORS

*
Can someone help me to figure out the problem and how I can solve it.

Regards,

Eloge B.

Responses

Hi Eloge Bapfunya,

That message says that the required repos for RHEL8 are not available over there. Btw, did you run the "leapp preupgrade" command before running "leapp upgrade" to check if the system meets all the requirements and qualifies for the upgrade? This should help you.

Thank your for your feeback. I had to create a composite content view on redhat with RHEL7 and RHEL8 repos. I still have trouble to force the host seeing RHEL 8.2 repos but I hope to sort it out shortly. This is the report I got:

Errors during downloading metadata for repository 'codeready-builder-for-rhel-8-x86_64-rpms':
  - Status code: 404 for https://xxxxxxxxxxxxx/pulp/repos/Default_Organization/Library/RHEL7et8/content/dist/rhel8/8.2/x86_64/codeready-builder/os/repodata/repomd.xml (IP: x.y.z)
Error: Failed to download metadata for repo 'codeready-builder-for-rhel-8-x86_64-rpms': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

I have to make RHEL 8.2 available on my host.

Regards,

Eloge B.

Eloge Bapfunya,

The error you mention on that repository, there seems to be some issue obviously with the codeready repo. Perhaps maybe recreate the content view for that specific repo? However, see the solution below because it does not mention the necessity for that repo.

The article on Leapp upgrades mentions an important note in this article here using RHEL 8.4 and not 8.2. Just for reference, please check this Red Hat solution too, maybe, and if needed, submit a case to resolve the content view.

An additional reference is this old discussion here, but it was last updated in November and the info is dated since the Red Hat article Christian mentioned below said to use RHEL 8.4 now with an important note.

Also Christian Labisch mentioned this Red Hat article elsewhere which is good to keep in mind.

Kind Regards,
RJ

There is a give-away by Red Hat for those who participate in the LEAP upgrade, the details are at this link

Regards,
RJ

Thank RJ Hinton I have finally integrated codeReady Repo and all went well. I have new version of 8.2 installed from 7.9. However, I still have an issue on another node and I think I a missing a packege required to map repositories while running leapp upgrade. Here is the output error message I got:

[root@lbl01a leapp]# leapp upgrade
Loaded plugins: product-id, subscription-manager

============================================================
                           ERRORS
============================================================

2021-07-23 11:16:39.705852 [ERROR] Actor: pes_events_scanner Message: Cannot parse RepositoriesMap data properly
Detail: {u'Problem': u'Did not receive a message with mapped repositories'}

============================================================
                       END OF ERRORS
============================================================

Thank you in advance for your help.