Dependencies conflict

Latest response

sudo dnf update
[sudo] password for user:
Updating Subscription Management repositories.
Last metadata expiration check: 0:20:49 ago on Tue 06 Apr 2021 15:28:17 EEST.
Error:
Problem 1: cannot install the best update candidate for package flatpak-selinux-1.6.2-4.el8.noarch
- nothing provides selinux-policy >= 3.14.3-54.el8_3.3 needed by flatpak-selinux-1.6.2-6.el8_3.noarch
- nothing provides selinux-policy-base >= 3.14.3-54.el8_3.3 needed by flatpak-selinux-1.6.2-6.el8_3.noarch
Problem 2: package flatpak-1.6.2-6.el8_3.x86_64 requires (flatpak-selinux = 1.6.2-6.el8_3 if selinux-policy-targeted), but none of the providers can be installed
- cannot install the best update candidate for package selinux-policy-targeted-3.14.3-54.el8_3.2.noarch
- cannot install the best update candidate for package flatpak-1.6.2-4.el8.x86_64
- nothing provides selinux-policy >= 3.14.3-54.el8_3.3 needed by flatpak-selinux-1.6.2-6.el8_3.noarch
- nothing provides selinux-policy-base >= 3.14.3-54.el8_3.3 needed by flatpak-selinux-1.6.2-6.el8_3.noarch
Problem 3: problem with installed package selinux-policy-targeted-3.14.3-54.el8_3.2.noarch
- package flatpak-1.6.2-6.el8_3.x86_64 requires (flatpak-selinux = 1.6.2-6.el8_3 if selinux-policy-targeted), but none of the providers can be installed
- problem with installed package flatpak-1.6.2-4.el8.x86_64
- package flatpak-1.6.2-4.el8.x86_64 requires flatpak-session-helper(x86-64) = 1.6.2-4.el8, but none of the providers can be installed
- package flatpak-1.6.2-5.el8_3.x86_64 requires flatpak-session-helper(x86-64) = 1.6.2-5.el8_3, but none of the providers can be installed
- cannot install both flatpak-session-helper-1.6.2-6.el8_3.x86_64 and flatpak-session-helper-1.6.2-4.el8.x86_64
- cannot install both flatpak-session-helper-1.6.2-6.el8_3.x86_64 and flatpak-session-helper-1.6.2-5.el8_3.x86_64
- cannot install the best update candidate for package flatpak-session-helper-1.6.2-4.el8.x86_64
- nothing provides selinux-policy >= 3.14.3-54.el8_3.3 needed by flatpak-selinux-1.6.2-6.el8_3.noarch
- nothing provides selinux-policy-base >= 3.14.3-54.el8_3.3 needed by flatpak-selinux-1.6.2-6.el8_3.noarch
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

==================================
sudo dnf list selinux-policy
Updating Subscription Management repositories.
Last metadata expiration check: 0:04:39 ago on Tue 06 Apr 2021 15:28:17 EEST.
Installed Packages
selinux-policy.noarch 3.14.3-54.el8_3.2 @rhel-8-for-x86_64-baseos-rpms

==================================
What have I to do?

Responses

same problem here... :-(

Hi Alexander,

I could reproduce the issue ... please run dnf upgrade later again. We had exactly the same problem some time ago.
Once the updated selinux packages are available, the problem disappears by itself - last time it was one day later. :)

Regards,
Christian

Hello Alexander Potapenko,

The solution for this issue is documented in this KB: https://access.redhat.com/solutions/5763941

Hope this helps!

Hi Sadashiva,

Thanks for adding the link to the knowledge base article ... it describes exactly what I wrote above.

Problem : "The flatpak packages were released ahead of their dependencies. Until those packages
are released, installations of flatpak will fail with problems resolving dependencies."

Solution : Wait until the new selinux-policy and selinux-policy-targeted packages are available ... :)

Regards,
Christian

I'm sorry, it doesn't.

Hi Alexander,

The word "solution" Sadashiva used is a bit misleading ... I think he rather meant "description". :)

Regards,
Christian

I don't think it is misleading rather it is how we interpret the solution. The Solution clearly says to clear out cache and then run update and check if updated packages are available. Anyways, good to see that the problem has been taken care or fixed for end users.

Ok, thank you. Wait for the future. May be it comes, may be it does not.

You're welcome, Alexander ! Well, I assume that we won't have to wait too long. :)

To upgrade other packages just run sudo dnf upgrade --exclude=flatpak*

Regards,
Christian

Finally the update worked at my side! :-)

Great news ! Thanks for the information, Markus. :)

Regards,
Christian

I can cofirm it. It works! Thanks everybody.

Hi Alexander,

I can confirm what Markus reported ... it seems to be solved ... please run sudo dnf upgrade --refresh again. :)

Regards,
Christian

Thank you, please close the ticket.

Hi Alexander,

This is a discussion portal, not a support desk ... so there is no ticket we can close. :)
Anyways, I'm glad that Red Hat solved the problem in such a very short time frame.

Regards,
Christian