Memcached/Keystone RHOSP 13 max_memory setting

Latest response

Hi,

I've notice that the memcached process on the controllers over the past couple of weeks is increasing the amount of memory its using. In the last 4 days its increased by 2GB.

The article https://access.redhat.com/solutions/4220701 makes reference to a max_memory setting and comments memcached by default uses 50% of the available memory. But this article relates to the undercloud memcache configuration.

Is there a similar setting for the overcloud , when memcached is used for caching keystone. ref https://access.redhat.com/solutions/3679131

I've looked the in keystone.conf file and there doesn't seem to be.

Does memcached have the same default behaviour of using 50% of available memory on the controllers ?

Thanks
Michael

Responses

The MemcachedMaxMemory overcloud parameter is what you want. Add the parameter to an environment file:

parameter_defaults:
  MemcachedMaxMemory: 25%

And include the environment file with your deployment.

You can also use either a percentage ('50%') or a fixed value ('2048') for MemcachedMaxMemory.

Thanks Daniel,

I'll give that a go