RHEL 8 Network install fails

Latest response
  1. Installation tree copied to /var/www/html/rhel8-install/ as outlined in the KB. Then restorecon -rv /var/www/html to ensure all security contexts were restored. Verified all are httpd_sys_content_t
  2. opened port 80 and added http service in firewall
  3. started httpd service and tried restart again.

Using virt-install all files are available from local network along with kickstart file in /var/www/html/ks.cfg.

[root@rhel8 Downloads]# virt-install --name tester --disk size=20 --memory 4096 --noautoconsole --wait=-1 --location "http://172.16.247.108/rhel8-install" --extra-args "ks=http://172.16.247.108/ks.cfg"
When installation begins:
Reached basic target system: (then)
"...anaconda failed to fetch kickstart from http://172.16.247.108/*' failed!
"0curl: (7) Failed to connect to 172.16.247.108 port 80: Connection refused

--------- Or without the kickstart file (--extra-args): ---------
[root@rhel8 Downloads]# virt-install --name tester --disk size=20 --memory 4096 --noautoconsole --wait=-1 --location "http://172.16.247.108/rhel8-install" :

"Warning: Downloading 'http://172.16.247.108/*' failed!
"0curl: (7) Failed to connect to 172.16.247.108 port 80: Connection refused

[root@rhel8 Downloads]# virt-install --name tester --disk size=20 --memory 4096 --noautoconsole --wait=-1 --location "http://172.16.247.108/rhel8-install" --extra-args "ks=http://172.16.247.108/ks.cfg"

I attached audit.log(txt), message.log(txt) and httpd_access.log(txt), but hopefully there is not any critical info i shared?

Attachments

Responses

Does using ks=http://192.168.122.1/ks.cfg work? I presume from the logs that the guest is using the 192.168.122.47 address on the virbr0 network so I am wondering if using 192.168.122.1, which I assume will be your computer's address on virbr0, will work any better.

That didn't work. I saw that line and not sure what that indicates. My webserver ad resources (rhel8-install media and ks.cfg) are all available from other computers on the network...

From https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/configuring_and_managing_virtualization/getting-started-with-virtualization-in-rhel-8_configuring-and-managing-virtualization i checked and found a warning. Odd thing is the virtualization worked fine on RHEL 7.
QEMU: Checking for device assignment IOMMU support : WARN (No ACPI IVRS table found, IOMMU either disabled in BIOS or not supported by this hardware platform)

seems to be an issue with KVM setup/config or with the network install setup. If the media is avaiable via web browser, then it should be fine, yeah?