Upgrade from RHEL 7.8 to RHEL 8.0 not to Latest RHEL 8.2

Latest response

Hello Champs,

I need to upgrade it to 8.1 not to 8.2 (Latest), our application supports only 8.1. So i downloaded 8.1 Binary DVD and created local repo and initiated upgrade from RHEL 7.8 to 8.1 Using "Upgrading to RHEL 8 without Red Hat Subscription Manager" Method #leapp upgrade --no-rhsm --enablerepo "localrepo". But we are getting error like "Problem 14: cannot install the best update candidate for package perl-4:5.16.3-295.el7.x86_64". Appreciate for any suggestions.

Responses

Hi Mohmed,

I am afraid that most of us customers cannot help you. You try something that is not supported.

I do not know if Red Hatters here have a clue how to do this.

Regards,

Jan Gerrit Kootstra

Mohmed

Please see this Red Hat discussion https://access.redhat.com/discussions/4356841 in it's context, also - please see this Red Hat article on supported in-place upgrades updated May 22, 2020 which will highlight what Jan said above. It seems Red Hat only supports LEAPP upgrades mentioned in that article (it will change over time, so I did not cite the versions in my reply here).

One alternative, take the system you have and use a "P to V" (physical to virtual) conversion where you make a clone of it of sorts to perhaps VMware or another virtualized system. I'm glad you asked why - so you can use a virtual system to attempt your LEAPP upgrade if you decide to go to 8.1 (not supported by Red Hat as I type this, they support going to 8.2 as I type this today).

Another alternative, build a fresh new from-scratch RHEL 8.1 system (virtual for development, and get a developer's edition of Red Hat Server for development purposes at https://developers.redhat.com) then attempt to install your application on the fresh new RHEL 8.1 system you made. BENEFIT OF THIS: You will still have your RHEL 7.8 system you mentioned in your original post that you can use for as a working valid reference and you can compare them as you develop your 8.1 RHEL system. You will also ditch the risk of a LEAPP upgrade because a LEAPP upgrade while supported by Red Hat (see article above) incurs risk and it may not go well, one does not know, there is no guarantee.

One more option, open a case with Red Hat and consider adding support to your app to 8.2, or just try it (virtual system) on 8.2.

If you use virtual systems, take snapshots before performing something risky so you can revert to your last snapshot. Please have a backup plan along the way, snapshots, code backups, configuration backups just in case something does not go as intended during your journey with this.

Regards,
RJ

Hi Mohmed,

To make it short and precise, I'm gonna summarize what my esteemed Red Hat Accelerators colleagues already told you.
What you are trying to achieve won't work - perform a fresh installation of RHEL 8.1, or update the application in order to
make it being compatible with RHEL 8.2 ... and even then - a fresh installation of RHEL 8.2 is definitely recommended ! :)

Regards,
Christian

Hi Mohned,

To add to the great remarks made by RJ and Christain, get Red Hat and the software vendor involved.

E.g. does the vendor support a LEAPP upgrade or do they only support a re-install on RHEL 8.1?

Reards,

Jan Gerrit Kootstra

Thank you guys (Jan, Hinton,Christian) for your valuable inputs.

Actually our system is running in VMware as a VM, i took a snapshot before upgrading and tried below methods,

  1. RHEL 7.5 --> 7.8 -- Leap Upgrade (leapp upgrade --no-rhsm --enablerepo "localrepo")-- 8.0 (Failed)
  2. RHEL 7.5 --> 7.8 -- Leap Upgrade (leapp upgrade --no-rhsm --enablerepo "localrepo")-- 8.1 (Failed)
  3. RHEL 7.5 --> 7.8 -- Leap Upgrade (leapp upgrade)-- 8.2 (Success)
  4. RHEL 8.2 --> 8.1 (Success) -- Downgrade only Kernel and redhat-release Packages

Not Sure whether its recommended approach.

Hi Mohmed,

Recommended ? No ! Now you have a mixture of RHEL 8.1 and RHEL 8.2 ... but it's your decision of course. :)

Regards,
Christian

Hi Mohmed,

A downgrade to a lower minor release is not a good idea, a partial downgrade is a bad idea. Most of the applications will not break due to a kernel release, but break on an unsupported library like glibc.

If you are still on 7.5 and want to use LEAPP, it would be better to upgrade to RHEL 7.6 (using a repo build from a DVD iso) and LEAPP to 8.1.

Regards,

Jan Gerrit

Thanks Christian and Jan for you valuable inputs. We rolled back using Snapshot to RHEL 7.5 again. We have OEM (HPE) Support only, we logged a case with HPE Redhat Support. Lets wait for their input.

Jan, i tried as you suggested, from RHEL 7.5 --> 7.6 than --> leapp upgrade but leapp upgrade requires RHEL 7.8 to upgrade it to 8.x (when we use leapp-data8.tar.gz). But am not sure whether i can use older leapp-data files like (leapp-data7.tar.gz) files and it may take it to 8.0 or 8.1.

For a successful in-place upgrade from Red Hat Enterprise Linux 7 to Red Hat Enterprise Linux 8, the Leapp utility requires data attached to this article to be placed in the /etc/leapp/files/ directory on the target system. The data files include RPM package changes (pes-events.json) and RPM repository mapping (repomap.csv) .