Configure Network button is greyed out during install

Latest response

I am installing a newly-purchased subscription of RHEL 6, using the 6.0 media kit provided by Red Hat. My symptom is identical to that described here: https://access.redhat.com/site/discussions/467643, although I have no solution.

Trying with the 6.4 media (Anaconda 13.21.195) the system hangs on 'Waiting for hardware to initialize...'. The 6.0 media (Anaconda 13.21.82) breezes past this, but does not recognize either wired or wireless network devices - symptom is greyed out 'Configure Network' button.

My concern of course is that the newly-purchased hardware I'm using isn't compatible with the rather old kernel. The system spec is here: http://www.toshiba.com/us/computers/laptops/qosmio/X70/X75-A7290. Before wiping out Windows, I confirmed that I had a wired connection, i.e. I know there's no hardware fault as such.

Some other diagnostics:

> lspci -nnk
07:00.0 Network controller [0280]: Intel Corporation Device [8086:0887] (rev c4)
    Subsystem: Intel Corporation Device [8086:4062]
0d:00.0 Ethernet controller [0200]: Atheros Communications Device [1969:1091] (rev 10)
    Subsystem: Toshiba America Info Systems Device [1179:fa77

> dmesg| grep intel
platform microcode: firmware: requesting intel-ucode/06-3c-0

Any suggestions would be most appreciated. And apologies for my ignorance.

Responses

Are you hoping to use only a wired or also a wireless connection?
(And is there any particular reason why you are using 6.0 instead of the newest update?)

I'll take what I can get, although preference is for wired.

I was just updating my question with additional info as you posted this. I've now tried the latest 6.4 freshly downloaded, and it hangs on first boot on the 'Waiting for hardware to initialize...' step.

Thanks for responding.

According to the vendor:device ID pairing [1], your network device is supported by the alx driver provided by ELRepo's kmod-alx [2]. Please see ELRepo's home page for more info about this repository. Download the package from one of the mirrors and install it using rpm. These kmod packages are kABI-tracking, meaning they survive kernel updates transparently.

[1] http://elrepo.org/tiki/DeviceIDs
[2] http://elrepo.org/tiki/kmod-alx
[3] http://elrepo.org

I had run into a similar issue with IBM hardware, which turned out that it was searching for a floppy. I would try to figure out why the 6.4 install is not working.

reboot, and when the first screen appears, press tab
and after
> vmlinuz initrd=initrd.img
add
> vmlinuz initrd=initrd.img floppy.allowed_drive_mask=0

You should be able to press ALT-F2 (or F3, etc..) to see what it is hung up on and provide that back to this thread, it may help us figure out what additional boot flags you need.

Many thanks for the response, it is much appreciated. I did not know how to get at the kernel loading options.

Unfortunately appending 'floppy.allowed_drive_mask=0' did not work. Neither does hitting any of the function keys, with or without ALT, provide further info at the point it's hanging.

But your tip made me go check out other command-line options [1] and I added loglevel=7. I'm seeing 'unsupported hardware' messages but it scrolls past too quickly to read. Using boot_delay= suggests it's the 'Haswell HDMI Audio', presumably not critical.

The hang though happens after the kernel load, in Anaconda:

anaconda installer init version 13.21.195 starting
... various mounting filesystem commands
running install...
running /sbin/loader
detecting hardware...
waiting for hardware to initialize...

[1] https://www.kernel.org/doc/Documentation/kernel-parameters.txt

I'm kind of flighty... I didn't even notice we were talking about a laptop. Anywho ;-)

Had you found any documentation on noapic or noprobe and apci=off? The problem I have found with the laptops is how they seem to consolidate many functions to one chipset (apparently). So, if you disable what you think is bluetooth, the WLAN is no longer working too, etc... I imagine you can try to disable some of the onboard components, at least to get the OS, installed, and then go from there? I would disable the onboard sound (like you had eluded to).

It's been a while since I had installed RHEL on a laptop, so I'm afraid I'm a bit rusty. Feel free to check out this page, and try some of the options:
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/sn-bootoptions-hardware.html#sn-bootoptions-hwdetection

Thank you again. The documentation mentions 'acpi=off' in many places, but without any discussion as to its merits.

As far as I can google, ACPI and APCI are unrelated so I have not tried noapic/nolapic. Nor noprobe, because then I'd have to manually configure drivers for everything.

Given the depth of this thread, and the fact that the discussion has moved off the original subject, I think I will open a new question to ask for the community's experience on 'acpi=off' specifically.

I appreciate all of your assistance.

UPDATE: after Mr. Radtke's tips re. kernel command-line parameters and further Googling, I tried 'acpi=off' and was able to boot off RHEL 6.4 DVD. This ends up in grub.conf and so persists beyond the initial install.

HOWEVER, I'm not sure this is a 'solution' - turning off a big chunk of power mgmt may not be so 'cool'. The laptap battery charging, power saving and fan cooling apparently may be affected.

I tried other documented options to see if I could make it less drastic: 'acpi=ht' boots, all these other fail:
- acpi=noirq
- acpi=strict
- pci=noacpi
- pnpacpi=off

I would still be very interested if anybody in the community has some further advice on this subject.

Hey Bruce, I just recalled one other tremendously annoying aspect of Laptops built for a windows-centric world. There was something related to whether you had disabled a component while in Windows (via software) and rebooted to Linux and there was no way to re-enable the component again in Linux. I'll keep digging. Not that it is impacting you at the moment, but I thought I would mention it.

Were you able to get the system patched to current? There are some additional packages that deal with the fans and sensors, which may actually add kernel modules that may allow you to run acpi again.
I agree that the potential for issues by disabling power management might not be worth the risk. Hopefully somebody has some additional guidance.

Thank you for the response. Yes, I could install off the 6.4 media, register, do the initial update. I see there is an apcid system service, but I'm not sure if that's what you are referring to. So the $1.0e+6 question remains - is this 'fix' possibly a recipe for future disaster?

Two other points I failed to mention about in connection with this install:
1. I received a big fat "Unsupported Hardware Detected" message in the text part of the installer, prior to the GUI part starting. I'm not sure what triggers this or how seriously it should be taken.
2. Wireless networking (and sound) now work, without any additional config. The wired eth0 interface is still absent.

"The wired eth0 interface is still absent."

According to your original post, the ethernet device is Atheros Communications Device [1969:1091]. Please follow the suggestion in my earlier post and give ELRepo's kmod-alx a try.

Apologies - it was remiss of me not to respond earlier. Early on in this process I'd tried the kmod-alx-0.0-8 elrepo rpm and it resulted in a kernel panic, but that was on the original 6.0 media. I did re-try on RHEL 6.4, first with kmod-alx-0.0-6 and then kmod-alx-0.0-7 and both worked. I have wired networking.

I think this discussion should be closed; the remaining issues are moved to a clean thread: https://access.redhat.com/site/discussions/541953