GUI applications can't print RHEL 7.8

Latest response

In the organization where I work, we have several machines running RHEL 7.x and RHEL 8. I am trying to make a new image for RHEL 7.8 but I ran into a problem with the print driver. Normally, when I print on any of the other computers, the gui that wants to print (such as Firefox or LibreOffice) launches a gui client of the print driver (written in Python). I then select which printer I want, color vs black, etc. I can also run the gui print client from the command line. I installed the print driver on the 7.8 image, same as always, and tried to print a document using Firefox. The client did not appear, and the print job failed. When I tried to call the gui print client from command line, it worked perfectly fine. I tried this with other GUI applications like GIMP and LibreOffice but had no luck. I know the driver is working because the document printed. To me, it seems as if gui applications like LibreOffice don't have permission to run other gui applications. How can I fix this, or is the problem something else?

Responses

Hi, I would need more information about the print driver. Is it publicly available somewhere? How do the applications launch it?