Missing monitor ttys after boot and missed executing boot scripts

Latest response

After doing a restart (init 6), the system came up but the main monitor's "ttys" and graphical interface screen did not.
The only thing that changed was the kernel. Went from "2.6.32-358.14.1.el6.x86_64" to "358.23.2"
What changed? What happened? I have not made any changes to the boot process. It should have just come up, as it normally does. I did get the normal "chasing bars" screen on the monitor but when it would normally switch to the graphical interface to log in, it just sat there.

Everything else seemed to be working fine except I then noticed that a couple of scripts I have in the r5.d directory didn't execute. They have been in the folder for quite awhile and the system has been restarted a number of times, without any issues. I have done some exploring and have found that now, any script following the S99local script will not be executed. What's up with that?

Any help, suggestions would be appreciated. I have no idea where to look. I have checked the usual log files but don't see anything strange.

Responses

Hi Paul!

What output does grep initdefault /etc/inittab and runlevel provide?

Did you run fixfiles onboot after applying the kernel-patch? In case you did not, you might want to check /var/log/audit/audit.log for suspicious output.

Kind Regards,
Andreas

I'm running at level 5 and the files were fine.
I have solved the issue though. It looks like Red Hat has made changes to other programs and the way the startup scripts are run.
It will now NOT process any scripts in the rcx.d folders following the S99local (/etc/rc.local) script. It has in the past but not anymore. I renamed my scripts so that they are listed above the S99local script and they now function.
The other issue (no ttys being created) has been solved too. It turns out Red Hat has made changes. I had a process starting in the S99local (/etc/rc.local) script, which worked previously, which was not told to run in the background (&). I saw a thread which mentioned something about monitor ttys not functioning and they said that they had to add the ampersand (&) to the script.
Thanks for your interest.

Thanks for your feedback too. Always good to know about those little changes.