nova compute not starting

Latest response

I ran into a problem launching an instance. Looking around, I determined it's because nova compute was not started. In /var/log/nova/compute.log, I saw 5 errors like this:

2013-10-31 15:09:24.930 ERROR nova.compute.manager [req-06e4a986-c134-40ae-9420-2d21170dff60 None None] Instance 51003341-a898-cd52-8d89-75780ea8be2d found in the hypervisor, but not in the database

And then a CRITICAL error with:

2013-10-31 15:09:27.529 271623 CRITICAL nova [-] Unexpected error while running command.
Command: env LC_ALL=C LANG=C qemu-img info /root/work/openstack-testing/images/basevm.img
Exit code: 1
Stdout: ''
Stderr: "qemu-img: Could not open '/root/work/openstack-testing/images/basevm.img'\n"

That basevm.img image is VM image I was working on and is not related to OpenStack (and it does exist in the /root/work/openstack-testing/images directory). Note that if I run virsh list --all, I get:

 Id    Name                           State
 -     basevm                         shut off
 -     default16cvm                   shut off
 -     instance-00000037              shut off
 -     kvmnode1                       shut off
 -     numa16cvm                      shut off
 -     old-kvmtest-default8cvm        shut off

Only the instance-00000037 VM is an OpenStack VM and the other 5 (note it is 5 - same as the number of error messages above) are not OpenStack VMs/instances. The instance that was created and result in instance-00000037 no longer exists if I run a nova list command.

So, any ideas on how to recover from this? If I try restarting the openstack-nova-compute service I just get the same errors that I mentioned above.