RHEL 8.3 Beta - testing experience

Latest response

Responses

First finding : There seems to be a bug in Anaconda of the boot.iso that makes it impossible to install the system.
I've retried it several times, added the option ip=dhcp to the boot parameters to ensure an internet connection.

Registration of the system fails with "[Erno -2] Name or service not known" - although the network is connected.
Looks as if the installer doesn't find my account and/or a valid Red Hat Beta subscription, which of course I have.

Main problem : The netinstaller functionality can only be used when the install medium is connected to the CDN.
To make sure that this was not a temporary issue, I booted with the RHEL 8.2 boot.iso and could register at once.

Update : Two of my Accelerators friends, Jan Gerrit Kootstra and John T. Mills, confirmed what I have detected.
Jan Gerrit reported the same issue with the dvd.iso as well - he couldn't register from within Anaconda installer.

I used the dvd.iso and encountered the same issue.

Thanks for confirming, Akemi ! I've sent a mail to the relevant team ... waiting for a response. :)

Regards,
Christian

A RHEL team member asked me to file a bug report -> https://bugzilla.redhat.com/show_bug.cgi?id=1862116

I think I have got a stage further. On the Connect to Red Hat page, if I expand the Options section, tick Custom server URL and set to subscription.rhsm.redhat.com I can register successfully.

Super cool, Michael ... that worked indeed - Thank you very much ! :)
Now the next step - Installation source - Red Hat CDN gives us this :
"Error setting up base repository" ... I am talking about the boot.iso !

Regards,
Christian

I got around that eventually by hand editing /etc/yum.repos.d/redhat.repo and adding https://cdn.redhat.com/ to the paths though that install is still running so I haven't gone back and looked at the clean state. I currently suspect the /etc/rhsm/rhsm.conf file generated in the install is missing some settings (for baseurl and possibly hostname)

What an adventure ... :D :D :D

Hi Michael,

I have added these two URL's after selecting "On the network" ->
https://cdn.redhat.com/content/beta/rhel8/8/x86_64/baseos/os https://cdn.redhat.com/content/beta/rhel8/8/x86_64/appstream/os
Still no chance - same error - seems this beta boot.iso is unusable ... :)

Regards,
Christian

It looks like the right way to do it is to set Custom base URL to https://cdn.redhat.com in addition to setting Custom server URL to subscription.rhsm.redhat.com . It looks like if these options aren't ticked the values get set to the blank string rather than a sensible default.

Hi Michael,

Great finding ... doing exactly this lets us (finally) install the beta system.
What a journey man - thanks a lot for your assistance and your efforts ! :)

Regards,
Christian

Update : Martin Kolman found the root cause for the bug - and Samantha Bueno confirmed that this will be fixed in the GA release.