Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=keycloak-jaas; type=karaf.feature; version="[10.0.2,10.0.2]

Latest response

feature:repo-add mvn:org.keycloak/keycloak-osgi-features/10.0.2/xml/features
feature:install -v keycloak-jaas

Gives...

Error executing command: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=keycloak-jaas; type=karaf.feature; version="[10.0.2,10.0.2]"; filter:="(&(osgi.identity=keycloak-jaas)(type=karaf.feature)(version>=10.0.2)(version<=10.0.2))" [caused by: Unable to resolve keycloak-jaas/10.0.2: missing requirement [keycloak-jaas/10.0.2] osgi.identity; osgi.identity=org.keycloak.keycloak-osgi-jaas; type=osgi.bundle; version="[10.0.2,10.0.2]"; resolution:=mandatory [caused by: Unable to resolve org.keycloak.keycloak-osgi-jaas/10.0.2: missing requirement [org.keycloak.keycloak-osgi-jaas/10.0.2] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.keycloak.adapters.jaas)(version>=10.0.2))" [caused by: Unable to resolve org.keycloak.keycloak-adapter-core/10.0.2: missing requirement [org.keycloak.keycloak-adapter-core/10.0.2] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.http)(version>=4.4.13))"]]]

Responses

The feature repository that you have added is not supported by Red Hat. You can tell this by the version, 10.0.2, which does not have 'redhat' in it. A typical Red Hat supported package has a version like 9.0.4.redhat-00001. To install Keycloak for Fuse 7.6, I recommend that you follow the instructions in the RH-SSO 7.3 guide (because Fuse 7.6 is aligned with RH SSO 7.3):

RH SSO 7.3 - 2.1.5. JBoss Fuse 7 Adapter

In section 2.1.5 of that guide, you can see that the recommended command for installing the feature repository is:

feature:repo-add mvn:org.keycloak/keycloak-osgi-features/4.8.20.Final-redhat-00001/xml/features

Incidentally, with respect to the error you saw above, it looks like the most deeply nested "caused by" clause is the missing dependency on the package org.apache.http with the version restriction, version>=4.4.13. Most likely, this version of org.apache.http is unsupported by the Red Hat distribution of Karaf (and thus not provided out of the box).