Trying to install EPEL repo (Hangs)

Latest response

Hi!
I've a server were I'm trying to install the epel repo.
The server is fully updated and is using a proxy.

I'm trying to install it using the following command:

yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

But It hangs...

"[root@someserver user]# yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
Loaded plugins: product-id, search-disabled-repos, subscription-manager
"

And after some time it says:
"
Cannot open: https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm. Skipping."

What have I missed? doing yum update etc. works like a charm.

//P

Responses

Hi Patrik,

The same command works here. That sounds a issue on the network to the server, dl.fedoraproject.org.

It's worth to try with http://, not https://, for testing.

# yum install http://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Another suggestion is checking if it can download it with curl.

# curl -O https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

If it's done successfully, install it with yum.

# yum install epel-release-latest-7.noarch.rpm

If the curl fails, check your network to connect dl.fedoraproject.org or any external server on internet.

Hi! I've tried with http and it didnt work, and couldn't see any deny's by the proxy either. What did work was to sftp the rpm file and then do a rpm -ivh on it, could it have something do to with the gpg keys or similar?

As for now it works doing that way but I would like to know what I've missed causing it not to work with "yum install http://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm"

Would you please elaborate the process of "sftp the rpm file and then do a rpm -ivh on it"? I just have started using red hat and it's hard for me to scrutinize the linux jargons.

I tried both the approaches using "http://", which hanged the system just as "https://" and then "curl" did not show any progress. Is there anything previously required to install this?

Patrik,

Install the rpm "elinks" and then attempt to navigate with elinks to let's say http://mirror.arizona.edu/fedora-epel/7/x86_64/

yum -y install elinks

If it installs, try this (not as root, hit the "ESC" key to get out of elinks.):

elinks http://mirror.arizona.edu/fedora-epel/7/x86_64/

If you can "navigate" using that text-based "elinks" command, you'll get a text-based browser showing the contents of the URL.

As a test, I also just made a /etc/yum.repos.d/epel.repo such as:

[manual_epel_file]
name=mirror.arizona.edu
baseurl=http://mirror.arizona.edu/fedora-epel/7/x86_64/
enabled=1
gpgcheck=0 #generally make this 1 and add and ingest the key

Then save/quit the file (make sure you are root when you create the file) then do the following command

yum repolist

NOTE: The above is just a test to determine if you can or can not make a manual EPEL file and make it work. The RPM method to ingest is generally better as Masahiro Matsuya says. You can pick a different location using one of EPEL's many mirrors.

NOTE 2: If this fails, validate your network settings, attempt to ping your gateway, and the IP address of 8.8.8.8 (Google's DNS), and perform other network diagnoses.

Regards, RJ

Hi Patrick,

Did you provide the operating system with proxy settings?

By default bash does not provide proxy settings, so it will try to resolve the url via a DNS query, that fails if your internal DNS does not resolve external website urls.

Sftp worked? So your proxy does not stop ssh?

Regards,

Jan Gerrit Kootstra