Installing LaTeX on RHEL8

Latest response

when I tried to run latex RHEL said:

bash: latex: command not found...
Install package 'texlive-latex' to provide command 'latex'? [N/y]

and I said y

however, then I got

Failed to install packages: Cannot download Packages/t/texlive-qstest-20180414-14.el8.noarch.rpm: All mirrors were tried; Last error: Curl error (6): Couldn't resolve host name for https://cdn.redhat.com/content/dist/rhel8/8/x86_64/appstream/os/Packages/t/texlive-qstest-20180414-14.el8.noarch.rpm [Could not resolve host: cdn.redhat.com]

I also tried installing LaTeX via

dnf install texlive-scheme-full (like in Fedora)

but dnf said
Unable to find a match: texlive-scheme-full

when try

dnf search texlive

I can find hundreds of packages - which of these do I actually need to install to get LaTeX working on RHEL8?

Responses

I now installed texlive via sudo dnf install texlive (without /scheme-full) and the installation seems to be pretty complete. However, when I try to compile slides I am still missing the translator.sty this seems to be a known bug: https://bugzilla.redhat.com/show_bug.cgi?id=1797151 Does anybody know a workaround?

Jan, it seems the most risk-averse approach is to install texlive with its own package installer as descibed here: https://www.tug.org/texlive/quickinstall.html Then you use tlmgr to add/update packages. The only tricky bit is the 'add to path' bit, but if you do it right you;ll end up with the latest version of texlive. I'm not sure how up to date the rhel version is.

thanks, Victor - actually, I was missing a few more style files: a4wide.sty DejaVuSansMono.sty DejaVuSerif.sty pbox.sty boxhandler.sty DejaVuSans.sty luainputenc.sty However, after downloaded them and put them into ~/texmf/tex/latex/local I could compile all my sources on RHEL8 (on Fedora this works right after installing texlive-scheme-full)

I also had to manually copy the pst-tools directory from an other computer (with Fedora) into texmf/tex/generic before I could compile documents using PSTricks, although I installed texlive-pstricks via dnf

And I am still looking for a package equivalent to the Fedora package texlive-svg for RHEL

the command \usepackage{svg} is not working for me