RHEL7.7 - Cannot "Switch Users" from lockscreen

Latest response

I am running RHEL7.7 x86_64 w/kernel 3.10.0-1062.7.1 on one system running an AMD FirePro W9100 video card and another system running a Radeon HD 5770.

I am using Gnome Classic as my desktop and after the screen locks (either from SUPER+L or screensaver timeout), I can no longer "Switch User" from the lock screen.

This used to work back in fall 2019, but I do not know exactly when it broke.

I am using the radeon driver in the kernel and whenever I attempt a "Switch User", xorg.log has the following error:

[XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

I can also trigger the same error when switching to a different tty via CTRL+ALT+F2 through F4, logging in as any user (including root), then issuing startx.

In both systems, if I swap in temporarily an nvidia card (using kernel nouveau drvier), user-switching from the GUI works with no issues.

My only hunch is an update to libdrm broke the DRM interface with radeon kernel driver per following, unrelated post about multi-GPU setup with the Bumblebee project:

https://github.com/Bumblebee-Project/Bumblebee/issues/652#issuecomment-167753870

Given it took so long to finally address this issue, I can no longer yum history rollback to fall 2019 since my repos don't store packages that long.

Anyone else run into this issue? Should I open a ticket with Red Hat?

FYI, I am having troubles installing the opensource amdgpu and closed sourced amdgpu-pro and AMD's official response to me is "we don't support RHEL 7.7, only 7.6". My best bet I think is sticking with RH and the radeon kernel driver.

Responses

Hi,

We believe is the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1789741. We fixed it in RHEL 7.7 will be available in the next RHEL 7.7 batch update. Let us know if you have further problems after updating, once the update is available.

Regards, Carlos

Worked! Thank you, Carlos!