Failed to download metadata for repo 'rhel-8-for-x86_64-baseos-rpms'

Latest response

Good afternoon I am using RED HAT for the first time, and when I am executing a command to update the yum (yum update) I find this error that I can not solve:

[root@srvdevrma1 ~]# yum update
Updating Subscription Management repositories.
Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 0.0 B/s | 0 B 00:00
Failed to download metadata for repo 'rhel-8-for-x86_64-baseos-rpms'
Error: Failed to download metadata for repo 'rhel-8-for-x86_64-baseos-rpms'

What can it be or how could it be solved?

Responses

Hi Cesar,

It might be a temporary issue with the Red Hat servers ... you can try if the following procedure solves the problem - it often does. :)

sudo dnf clean all
sudo rm -r /var/cache/dnf
sudo dnf upgrade

Regards,
Christian

I still get the same error after executing the previous commands, I don't understand why

Hi. This didn't resolve the issue for me. Using the verbose flag can help identify the cause of the issue, e.g. sudo dnf upgrade -v

I still get the same error after executing the previous commands, I don't understand why

Hi Cesar,

As I said, it might be a temporary issue with the Red Hat servers. Wait a little bit and try it again later.
In case the problem persists for a longer time, I recommend to contact Red Hat Customer Service. :)

Regards,
Christian

I got same issue,By the way,have you solved it?

I am having the same issue Red Hat Enterprise Linux 8 for x86_64 - BaseOS 79 B/s | 10 B 00:00
Failed to download metadata for repo 'rhel-8-for-x86_64-baseos-rpms' Error: Failed to download metadata for repo 'rhel-8-for-x86_64-baseos-rpms'

I managed to solve my problem by commenting a line in the rhsm.conf configuration file, specifically the line "proxy_scheme = https", in my case I use proxy in my company. I hope I can solve the problem for you

Hi Cesar,

Glad to read that you could solve the problem. :)

Regards,
Christian

[root@srvdevrma1 ~]# yum update Updating Subscription Management repositories. Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 0.0 B/s | 0 B 00:00 Failed to download metadata for repo 'rhel-8-for-x86_64-baseos-rpms' Error: Failed to download metadata for repo 'rhel-8-for-x86_64-baseos-rpm

what can i do now

Hi ! :)

What you can do ? Well, I suggest you just read my first two responses above ... :)

Regards,
Christian

I had this issue and found out I was using the wrong release. https://access.redhat.com/solutions/4762961 .

subscription-manager release --show

Release not set

Once I set my version, my issue was resolved.

subscription-manager release --set=8.1

This worked for me.. I forgot to set the release in the activation key on my Satellite..

This worked for me as well

dsys unm post, solved me too!

Thank you. This fixes the problem!

I had install 8.2 and the O/S updated it to 8.5. When I checked release version on Server it said 8.5.

I ran the command It fixed the problem. Thanks so much!

Worked for me.Thank you.

Great. That's work for me.

Thanks this solution worked for me

subscription-manager release --set=8.6 worked for me. Thanks!

Hi All,

please cleanup unwanted repo file under /et/yum.repos.d/ dir. i mean you keep only subscribed repository . Like redhat.repo.

yum clean all subscription-manager refresh yum list perl

It works for me

hello sir, thanks for your suggestion, it work for me, i am new learner in red hat, thanks you again.

yum clean all subscription-manager refresh yum list perl

I've tried all of the above but still does not work. Still get the same issue "Failed to download metadata for repo 'rhel-8-for-x86_64-baseos-rpm". Any help?

I've tried everything above and it has resolved some issues that I didn't even realize that I had. However, I'm still getting this annoying line, (I know it's variations on a theme at this point): "Error: Failed to download metadata for repo 'satellite-tools-6.7-for-rhel-8-x86_64-e4s-source-rpms'" It's frustrating, but I'm still believing in the community. Let's fix this thing!!

Hi Miguel,

Do you have a Satellite installation ? If not, just disable this repository and the error message is gone. :)

Regards,
Christian

hi mayuresh i have some problem check plz This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register. Extra Packages for Enterprise Linux 8 - x86_64 0.0 B/s | 0 B 00:12
Failed to download metadata for repo 'epel' Error: Failed to download metadata for repo 'epel'

Hi Mayuresh,

This seems to be a temporary issue with the EPEL repository servers ... disable it and re-enable it at a later time. :)

Regards,
Christian

I fixed the issue. I had to de-register my development machine with the subscription manager, then re-register, then subscribe the machine again and set the release. I was then able to download packages again using yum without any of the previous issues. So: subscription-manager register --force (de-registers and re-registers in one command) subscription-manager subscribe (I then subscribed and got the following back... Installed Product Current Status: Product Name: Red Hat Enterprise Linux for x86_64 Status: Subscribed Then set my release (run the following to check what releases are available and match with yours) subscription-manager release --list (in my case 8.1 is my system look at /etc/redhat-release for version) subscription-manager release --set=8.1 (set my version) Then as a test installed GCC and all was good. Hope this helps someone ;-)

Hi Ian,

Of course it helps - not only someone ... I recommended this in many cases. Thank you for providing your solution. :)

Regards,
Christian

This solution fixed the issue for me as well.

This secret handshake is what fixed me as well. This is the second time I've had to do something like this just to do updates.

This should be upvoted. Worked for my self support subscription

This solution fixed the issue for me

Great... This solution fixed my issue.. Thank you..

Thank you so much. This worked for me.

This worked today with the same issue on RHEL 8.4.

My trouble has been resolved. Thank you

Thank you, this has fixed the problem multiple times for me.

Red Hat Satellite Tools 6.5 for RHEL 8 x86_64 - 2.3 B/s | 10 B 00:04
Failed to download metadata for repo 'satellite-tools-6.5-for-rhel-8-x86_64-e4s-debug-rpms'=========>> how to solve the issue. for this reason I cant install VLC on my rhel8 system

Issue resolved for me when disable and enable the repo again:

 # subscription-manager repos --disable fast-datapath-for-rhel-8-x86_64-rpms  
 # subscription-manager repos --enable fast-datapath-for-rhel-8-x86_64-rpms

Thanks - that fixed things for me

[root@node1 tomcat]# subscription-manager repos --disable rhel-8-for-x86_64-baseos-rpms Repository 'rhel-8-for-x86_64-baseos-rpms' is disabled for this system. [root@node1 tomcat]# subscription-manager repos --enable rhel-8-for-x86_64-baseos-rpms Repository 'rhel-8-for-x86_64-baseos-rpms' is enabled for this system. [root@node1 tomcat]# yum update Updating Subscription Management repositories. Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 8.8 MB/s | 14 MB 00:01 Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs) 8.7 MB/s | 14 MB 00:01 Dependencies resolved. Nothing to do. Complete! [root@node1 tomcat]#

Thanks - that fixed things for me

Thanks, that did the trick

doesn't work for me, :-(

subscription-manager refresh yum clean all yum repolist

^^ fixed it for me

That worked for me too - thxs

Also fixed it for me. Looks like an issue with a certificate used for https connections. Cleaning out the problem certificate with:

sudo subscription-manager refresh

Showed this message:

1 local certificate has been deleted.

Problem was resolved with the next yum update.

it is working after disabling of repo_gpgcheck=1

Thanks this worked for me

Pages