Switch Nouveau driver to Intel driver

Latest response

Dear Everybody

I have set-up a RHEL 8.0 dual system with ThinkPad P52 4K version using Xeon E-2176M & Intel UHD Graphics P630. Unfortunately, I can only use Nouveau driver which means only NVIDIA Quadro P2000 can work, but this is not power saving and every time when I boot to RHEL 8.0, I need set discrete Nvidia card in BIOS, so I want to know how to set-up only using Intel UHD Graphics P630 for display so in BIOS I can still using the hybrid setting.

Please anybody can give me some assistance with this display issue.

Responses

Hi ! :)

Disable the NVIDIA graphics adapter, select hybrid mode in BIOS. When the boot menu appears, press the E key.
Add nouveau.modeset=0at the end of the line beginning with linux - now press Ctrl + X to boot the system.

If you want to make it a permanent solution, edit the /etc/default/grub file : sudo vi /etc/default/grub
Add nouveau.modeset=0to the line GRUB_CMDLINE_LINUX. Afterwards save and close the changed file.

Now update the GRUB configuration : sudo grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg
Up until now there is no properly working solution to switch the behavior on the fly, reboots are required.

Regards,
Christian

I have tried your instructions just now, unfortunately this will cause black screen, maybe I should fully block nouveau driver, thanks for your advice :-), I will try again tomorrow.

Hi ! :)

Check out if creating this additional file solves the problem.

sudo vi /etc/modprobe.d/nouveau.conf

Insert these lines :

blacklist nouveau
options nouveau modeset=0

Regards,
Christian

Hi Christian

I have follow like this: 1. sudo vi /etc/default/grub --> add nouveau.modeset=0 to the line GRUB_CMDLINE_LINUX

  1. sudo vi /etc/modprobe.d/nouveau.conf --> Insert these lines : blacklist nouveau options nouveau modeset=0

  2. sudo grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg

  3. set-up HYBRID mode in BIOS, then boot to RHEL 8.0.

But still cause black screen, even I add i915.alpha_support=1 and delete "rhgb" in /etc/default/grub, also can't login GUI Desktop.

Now I really don't know how to solve this issue.

Hi ! :) Just for testing : Does it work when you add the boot parameter nomodeset instead ?

Regards,
Christian

Hi

As I know Kernel 4.15 will support Coffee Lake, but according to my test of RHEL 8 & CentOS 8 Ubuntu 19.10 Pop!_OS which even the kernel version higher than 5.0, this issue still exist, means can't only use Intel UHD P630 for diaplay with HYBRID BIOS set.

Regards.

Hi ! :) RHEL 8 ships with kernel 4.18 and not with kernel 4.15 - just for your information ... oh, and one thing :
Because I don't know your real name I only say "Hi" - I assume "offshore Overseas" is not your real name. :D

Regards,
Christian

Hi ! :) I'm a bit confused, you say "can't only use Intel UHD P630 for display with HYBRID BIOS set".
Does this ("can't"/"only") mean that your intel adapter works in hybrid mode ? Or does it not work ?

Regards,
Christian

Dear Christian

I'm sorry for hidden my info, I'm Mr Li from China, but work in Kathmandu/Nepal for one China company, due to my curiosity, I want to set-up a Linux laptop.

My intention is using Hybrid display set (which I using when booting to Windows 10) to boot in to RHEL 8, so every time there is no need to switch to discrete display setting, and the RHEL 8 System setting-->Details-->About should show Graphics is Intel Graphics UHD P630, not NV137.

Now the "lspci | grep -i vga“ only show NVIDIA Quadro P2000 diaplay card, which I think P630 doesn't work.

Regards.

Hi Mr. Li,

This most probably means that it has only to do with BIOS settings. In the Details both cards
should be visible. Best would be to contact lenovo support and ask them how to achieve it. :)

Regards,
Christian