Cannot install Satellite

Latest response

Hi,

I'm trying to deploy Redhat Satellite using the following software ISO's...

rhel-server-7.6-x86_64-dvd.iso
satellite-6.5.1-rhel-7-x86_64-dvd.iso

I am running the Satellite installer and I have the following error...

Error: Package: foreman-selinux-1.20.0-1.el7sat.noarch (satellite-local)
Requires: selinux-policy >= 3.13.1-229.el7_6.5
Installed: selinux-policy-3.13.1-229.el7.noarch (@anaconda/7.6)

The error is repeated for pulp-selinux and candlepin-selinux.

It appears to be some kind of package dependency but I am using the latest packages available. From the Redhat downloads these are the only versions available?

Any idea what software I need to get this working?

Thanks

Responses

Hello, I think simultaneously installing selinux-policy and selinux-policy-targeted with the latest versions for RHEL7.6 will fix this. Download the packages from the portal.

Hello Thomas,

Will you use the Satellite connected or disconnected?

If connected, add the Satellite repository to the server.

If disconnected Stephen's way should be used, for each package the installer complains about. Can be time consuming.

Regards,

Jan Gerrit Kootstra

Yes, sorry I neglected to say. This is a disconnected environment. Thanks for your responses. Sounds like I need those two packages... I downloaded these...

selinux-policy-targeted-3.13.1-229.el7_6.15.noarch.rpm selinux-policy-3.13.1-229.el7_6.15.noarch.rpm

They appear to be the latest although they have a different filename from the suggested 3.13.1-229.el7_6.5.

Lets hope they help.

Unfortunately this did not help resolve the issue at all. Further dependencies occurred when trying to install these packages as well. The dependencies listed appeared to be the same packages that were already installed.

I think I had to have RHSCL (Red Hat software collections) when I installed satellite for my disconnected satellites. **However please refer to these instructions for satellite 6.5.1 for a disconnected environment

I'm going to be doing an install myself this week, maybe tomorrow of Satellite 6.5.1. I'll post back here.

Regards

RJ

Hi,

This could not be fixed. I deployed another system using the rhel-server-7.7-x86_64-dvd.iso. This issues did not exist for this distribution. The fix therefore is to deploy RHEL 7.7 when using Satellite 6.5.1 (satellite-6.5.1-rhel-7-x86_64-dvd.iso) on a disconnected system.

Thanks for all your help.

Indeed, any Satellite minor/z-stream version is built/verified/supported against the latest RHEL version (available at the moment of GA of the Satellite version). For Sat6.5.1, it was RHEL7.7.

Thomas Bridle,

Thank you for posting this. I'm building a satellite 6.5.1 today. I was planning on using RHEL 7.7 but this will help others. I added a comment to https://access.redhat.com/solutions/3673971 (near the bottom) asking Red Hat to update that article to include the scope of 6.5.1. It seems the versions are slightly different with what you experienced and what the solution ID above cites. I've asked Red Hat to look at this, and also to consider updating the common satellite issues cited at this link

Regards

RJ

Satellite 6.5.2.1 was the cleanest smoothest satellite installation I've ever done so far. I used these instructions. I used RHEL 7.7. I've built 2 satellite servers this week, both satellite servers have FIPS enabled.

Regards

RJ

Guys,

I'm having this same issue with RHEL 7.7 and Satellite 6.6. install script fails on selinux-policy version. However it seems like it is asking for the same version which is installed (!) Unfortunately I cannot use RHEL 8 since it has not been approved by our organisation for install as yet. Below are the error messages:

Error: Package: pulp-selinux-2.19.1.1-1.el7sat.noarch (InstallMedia)

Requires: selinux-policy >= 3.13.1-252.el7.1

Installed: selinux-policy-3.13.1-252.el7.noarch (@anaconda/7.7)

selinux-policy = 3.13.1-252.el7

Error: Package: candlepin-selinux-2.6.9-1.el7sat.noarch (InstallMedia)

Requires: selinux-policy >= 3.13.1-252.el7.1

Installed: selinux-policy-3.13.1-252.el7.noarch (@anaconda/7.7)

selinux-policy = 3.13.1-252.el7

Error while executing command: 'yum install -y satellite'

We have downloaded the latest selinux-policy package and tried to install it, but we get similar errors:

Error: Package: selinux-policy-targeted-3.13.1-252.el7.noarch (@anaconda/7.7)

Requires: selinux-policy >= 3.13.1-252.el7.1

Removing: selinux-policy-3.13.1-252.el7.noarch (@anaconda/7.7)

selinux-policy >= 3.13.1-252.el7

Updated By: selinux-policy-3.13.1-252.el7_7.6.noarch (/selinux-policy-3.13.1-252.el7_7.6.noarch)

selinux-policy = 3.13.1-252.el7_7.6

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

Please help. Thanks

Hello Zafar,

RHEL 8.x is not supported for Satellite 6.y at the moment, so it will not fix the issue at hand.

A few questions come to mind:

  • Did you check all the requirements as mention in the installation guide?

    • Have you registered the RHEL 7.7 server to CDN or another RH Satellite and applied all available patches before starting the Satellite installation?

Hi Jan,

Thanks for your prompt response.

I have rechecked all requirements in the install guide and the server meets all of them. I cannot register the server to either the CDN or another RH Satellite because this server is on a restricted network, so it has no access to the internet or another Satellite.

Zafar,

I see version difference: selinux-policy-3.13.1-252.el7_7.6 and selinux-policy-3.13.1-252.el7 in your error messages. On my Satellite 6.6.1 I have selinux-policy-3.13.1-252.el7_7.6 installed.

Do you have your DVD iso's both RHEL and Satellite mounted and created a on server repository for both products?

Maybe that could resolve the issues.

Regards,

Jan Gerrit Kootstra

Hi Jan,

I have both DVDs mounted. The error message involving selinux-policy-3.13.1-252.el7_7.6 only occurs when I try to update the installed selinux-policy-3.13.1-252.el7 with the one I've downloaded from Redhat: selinux-policy-3.13.1-252.el7_7.6. I am updating that, because the install of Satellite 6.6 fails on the version of selinux-policy which is version 3.13.1-252.el7.

Jan,

Upgrading BOTH selinux-policy & selinux-policy-targeted to the latest versions fixes this problem.

Thanks for your help.

Zafar

Indeed. Satellite6 is supported only on up-to-date RHEL7 operating system. This precondition was broken, until you updated the few packages.

Anyway I recommend to run plain "yum update" (well, with --disableplugin=foreman-protector :) ) to update other OS packages, to prevent future potential issues caused by Sat6.6 relying on fully updated OS.

Glad you got this figured out Zafar Iqbal. Jan is a great resource.

Regards
RJ

Hi Everyone,

I spent almost half day of trying but couldn't fix it. here are the logs

[root@rhnsat sat6]# ./install_packages This script will install the satellite packages on the current machine. - Ensuring we are in an expected directory. - Copying installation files. - Creating a Repository File - Creating RHSCL Repository File - Creating sat-maintenance Repository File - Checking to see if Satellite is already installed. - Importing the gpg key. Error: Package: foreman-selinux-1.24.1-1.el7sat.noarch (satellite-local) Requires: selinux-policy >= 3.13.1-252.el7_7.6 Installed: selinux-policy-3.13.1-252.el7.noarch (@anaconda/7.7) selinux-policy = 3.13.1-252.el7 Error: Package: candlepin-selinux-2.9.25-1.el7sat.noarch (satellite-local) Requires: selinux-policy >= 3.13.1-252.el7_7.6 Installed: selinux-policy-3.13.1-252.el7.noarch (@anaconda/7.7) selinux-policy = 3.13.1-252.el7 Error: Package: pulp-selinux-2.21.0.1-1.el7sat.noarch (satellite-local) Requires: selinux-policy >= 3.13.1-266.el7 Installed: selinux-policy-3.13.1-252.el7.noarch (@anaconda/7.7) selinux-policy = 3.13.1-252.el7 Error while executing command: 'yum install -y satellite' [root@rhnsat sat6]# re

[root@rhnsat RPM]# cd ../sat6/ [root@rhnsat sat6]# ./install_packages This script will install the satellite packages on the current machine. - Ensuring we are in an expected directory. - Copying installation files. - Creating a Repository File - Creating RHSCL Repository File - Creating sat-maintenance Repository File - Checking to see if Satellite is already installed. - Importing the gpg key. Error: Package: pulp-selinux-2.21.0.1-1.el7sat.noarch (satellite-local) Requires: selinux-policy >= 3.13.1-266.el7 Installed: selinux-policy-3.13.1-252.el7_7.6.noarch (@/selinux-policy-3.13.1-252.el7_7.6.noarch) selinux-policy = 3.13.1-252.el7_7.6 Available: selinux-policy-3.13.1-252.el7.noarch (InstallMedia) selinux-policy = 3.13.1-252.el7 Error while executing command: 'yum install -y satellite' [root@rhnsat sat6]#

Later on next day :) finally it worked this way but after several attempts

yum localinstall selinux-policy-3.13.1-266.el7.noarch.rpm selinux-policy-targeted-3.13.1-266.el7.noarch.rpm

Loaded plugins: product-id, search-disabled-repos, subscription-manager This system is not registered with an entitlement server. You can use subscription-manager to register. Examining selinux-policy-3.13.1-266.el7.noarch.rpm: selinux-policy-3.13.1-266.el7.noarch Marking selinux-policy-3.13.1-266.el7.noarch.rpm as an update to selinux-policy-3.13.1-252.el7_7.6.noarch Examining selinux-policy-targeted-3.13.1-266.el7.noarch.rpm: selinux-policy-targeted-3.13.1-266.el7.noarch Marking selinux-policy-targeted-3.13.1-266.el7.noarch.rpm as an update to selinux-policy-targeted-3.13.1-252.el7_7.6.noarch Resolving Dependencies --> Running transaction check ---> Package selinux-policy.noarch 0:3.13.1-252.el7_7.6 will be updated ---> Package selinux-policy.noarch 0:3.13.1-266.el7 will be an update ---> Package selinux-policy-targeted.noarch 0:3.13.1-252.el7_7.6 will be updated ---> Package selinux-policy-targeted.noarch 0:3.13.1-266.el7 will be an update --> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================ Package Arch Version Repository Size ================================================================================================================================================Updating: selinux-policy noarch 3.13.1-266.el7 /selinux-policy-3.13.1-266.el7.noarch 6.7 k selinux-policy-targeted noarch 3.13.1-266.el7 /selinux-policy-targeted-3.13.1-266.el7.noarch 19 M

Transaction Summary ================================================================================================================================================Upgrade 2 Packages

Total size: 19 M Is this ok [y/d/N]: y Downloading packages: Running transaction check Running transaction test Transaction test succeeded Running transaction Updating : selinux-policy-3.13.1-266.el7.noarch 1/4 Updating : selinux-policy-targeted-3.13.1-266.el7.noarch 2/4 Cleanup : selinux-policy-targeted-3.13.1-252.el7_7.6.noarch 3/4 Cleanup : selinux-policy-3.13.1-252.el7_7.6.noarch 4/4 Verifying : selinux-policy-targeted-3.13.1-266.el7.noarch 1/4 Verifying : selinux-policy-3.13.1-266.el7.noarch 2/4 Verifying : selinux-policy-3.13.1-252.el7_7.6.noarch 3/4 Verifying : selinux-policy-targeted-3.13.1-252.el7_7.6.noarch 4/4

Updated: selinux-policy.noarch 0:3.13.1-266.el7 selinux-policy-targeted.noarch 0:3.13.1-266.el7

Complete! [root@rhnsat RPM]# . ../sat6/install_packages -bash: import: command not found -bash: import: command not found -bash: import: command not found -bash: import: command not found -bash: import: command not found -bash: from: command not found -bash: ../sat6/install_packages: line 23: syntax error near unexpected token (' -bash: ../sat6/install_packages: line 23:def run_command(cmd):' [root@rhnsat RPM]# ^Cat6/install_packages [root@rhnsat RPM]# cd - /media/sat6 [root@rhnsat sat6]# ./install_packages This script will install the satellite packages on the current machine. - Ensuring we are in an expected directory. - Copying installation files. - Creating a Repository File - Creating RHSCL Repository File - Creating sat-maintenance Repository File - Checking to see if Satellite is already installed. - Importing the gpg key. - Installation repository will remain configured for future package installs. - Installation media can now be safely unmounted.

Install is complete. Please run satellite-installer --scenario satellite [root@rhnsat sat6]#

Thanks

Hello, indeed, Satellite GA version, as delivered on ISO, had that issue. It was soon fixed in an errata, such that connected deployments updated or installed smoothly. "Just" disconnected ones were offered the original ISO with the same problem. The cause is, we deliver ISOs for Y-streams, not for z-streams.