(RHEL 8) rd.live.check enabled by default

Latest response

KS image startThe rd.live.check (previously 'mediacheck') appears to be enabled by default when running a KS install.

In my KS file I'm running the install type as 'text' and do not have any reference to 'mediacheck' or 'rd.live.check'.

The documentation is for RHEL 7 (I don't see one yet for 8) but it says that this needs to be explicitly referenced in the KS file otherwise it won't be enabled.

"Options presented without the "=" sign do not accept any values or parameters. For example, the rd.live.check option forces Anaconda to verify the installation media before starting the installation; if this option is present, the check will be performed, and if it is not present, the check will be skipped. "
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/installation_guide/chap-anaconda-boot-options#list-boot-options-sources

However, my attached screenshot shows that it's calling rd.live.check in the boot command line. It was a quick screenshot before the window disappeared, hence the lack of the full 'http' line, but the rd.live.check is listed prior to that.

Any thoughts here, am I missing something? Thanks for any help you can give!

Responses

The equivalent RHEL8 document is probably here . It looks like you pressed Tab to edit the boot line and added options to it but the option selected when you pressed tab was the one with the media check in so I suggest you select the non-media check entry first before pressing Tab. Adding text here may not make much difference as it may get overridden with the settings in the kickstart file. Also you should be using inst.ks= not ks= .

Thanks Michael for the reply and documentation link. You are correct about the tabs. We are calling this build from Packer, and it was incorrectly putting the wrong number of TABs in the "boot_command" line. What previously worked for RHEL 7 is slightly different for RHEL 8.

Thank you for your help!