Unable to register during minishift startup

Latest response

When I execute command minishift start, I get following error

C:\Users\TEJESHKUNTE>minishift start
-- Starting profile 'minishift'
-- Check if deprecated options are used ... OK
-- Checking if https://mirror.openshift.com is reachable ... FAIL
-- Checking if requested OpenShift version 'v3.11.82' is valid ... SKIP
-- Checking if requested OpenShift version 'v3.11.82' is supported ... OK
-- Checking if requested hypervisor 'virtualbox' is supported on this platform ... OK
-- Checking if VirtualBox is installed ... OK
-- Checking the ISO URL ... OK
-- Checking if provided oc flags are supported ... OK
-- Starting the OpenShift cluster using 'virtualbox' hypervisor ...
-- Minishift VM will be configured with ...
Memory: 4 GB
vCPUs : 2
Disk size: 20 GB
-- Starting Minishift VM ................................. OK
-- Registering machine using subscription-manager
Retriving password from keychain ... OK
Login to registry.redhat.io in progress . FAIL
Registration in progress . FAIL [2s]
Error to register VM: ssh command error:
command : sudo -E subscription-manager register --auto-attach --username tvkunte --password ********
err : exit status 70
output : Registering to: subscription.rhsm.redhat.com:443/subscription
Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information.

Responses

Did you ever solve this? I'm having the same problem.

I have the same problem. Please let me know if this is solved.

I did get past this. My issue was the proxy I was using which was one on my local machine. I initally had http-proxy and https-proxy set up as localhost:3128 which worked for some of the process but at the point the registration was happening localhost would mean the local machine of the VM or even perhaps a Docker container in it. Therefore I set up my proxy address as my host machine's local IP address eg 10.0.1.28. The proxy I was using (Px) also needed to be set up as a gateway and not as hostonly. It also needed to have "allow" for the address of the minishift VM.

This is pretty specific to my scenario but I hope it helps someone.